summaryrefslogtreecommitdiff
path: root/dev-libs/botan/botan-3.0.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/botan/botan-3.0.0-r2.ebuild')
-rw-r--r--dev-libs/botan/botan-3.0.0-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-libs/botan/botan-3.0.0-r2.ebuild b/dev-libs/botan/botan-3.0.0-r2.ebuild
index fb1e9384a2cc..29f6c986af69 100644
--- a/dev-libs/botan/botan-3.0.0-r2.ebuild
+++ b/dev-libs/botan/botan-3.0.0-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/botan.asc
-inherit edo python-r1 toolchain-funcs verify-sig
+inherit edo multiprocessing python-r1 toolchain-funcs verify-sig
MY_P="Botan-${PV}"
DESCRIPTION="C++ crypto library"
@@ -176,7 +176,7 @@ src_configure() {
}
src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test$(ver_cut 1) || die "Validation tests failed"
+ LD_LIBRARY_PATH="${S}" edo ./botan-test$(ver_cut 1) --test-threads="$(makeopts_jobs)"
}
src_install() {