summaryrefslogtreecommitdiff
path: root/dev-libs/botan/botan-2.19.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/botan/botan-2.19.2.ebuild')
-rw-r--r--dev-libs/botan/botan-2.19.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-libs/botan/botan-2.19.2.ebuild b/dev-libs/botan/botan-2.19.2.ebuild
index e899feaea56b..9001823c1c74 100644
--- a/dev-libs/botan/botan-2.19.2.ebuild
+++ b/dev-libs/botan/botan-2.19.2.ebuild
@@ -3,9 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/botan.asc
-inherit edo python-r1 toolchain-funcs verify-sig
+inherit edo multiprocessing python-r1 toolchain-funcs verify-sig
MY_P="Botan-${PV}"
DESCRIPTION="C++ crypto library"
@@ -167,7 +167,7 @@ src_configure() {
}
src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+ LD_LIBRARY_PATH="${S}" edo ./botan-test --test-threads="$(makeopts_jobs)"
}
src_install() {