summaryrefslogtreecommitdiff
path: root/dev-libs/bcm2835/bcm2835-1.68-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/bcm2835/bcm2835-1.68-r1.ebuild')
-rw-r--r--dev-libs/bcm2835/bcm2835-1.68-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/bcm2835/bcm2835-1.68-r1.ebuild b/dev-libs/bcm2835/bcm2835-1.68-r1.ebuild
new file mode 100644
index 000000000000..6974a3fc9586
--- /dev/null
+++ b/dev-libs/bcm2835/bcm2835-1.68-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Provides access to GPIO and other IO functions on the Broadcom BCM2835"
+HOMEPAGE="https://www.airspayce.com/mikem/bcm2835/"
+SRC_URI="https://www.airspayce.com/mikem/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="doc examples"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/html/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ default
+}