summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-cal/aws-c-cal-0.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/aws-c-cal/aws-c-cal-0.4.5.ebuild')
-rw-r--r--dev-libs/aws-c-cal/aws-c-cal-0.4.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/aws-c-cal/aws-c-cal-0.4.5.ebuild b/dev-libs/aws-c-cal/aws-c-cal-0.4.5.ebuild
new file mode 100644
index 000000000000..407a8f3334d2
--- /dev/null
+++ b/dev-libs/aws-c-cal/aws-c-cal-0.4.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Crypto Abstraction Layer: Cross-Platform C99 wrapper for cryptography primitives"
+HOMEPAGE="https://github.com/awslabs/aws-c-cal"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ || (
+ >dev-util/cmake-3.19.1
+ <dev-util/cmake-3.19.0
+ )
+"
+
+DEPEND="
+ >=dev-libs/aws-c-common-0.4.62:=[static-libs=]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake-prefix.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}