summaryrefslogtreecommitdiff
path: root/dev-libs/atcore/atcore-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/atcore/atcore-1.0.0.ebuild')
-rw-r--r--dev-libs/atcore/atcore-1.0.0.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/dev-libs/atcore/atcore-1.0.0.ebuild b/dev-libs/atcore/atcore-1.0.0.ebuild
index bf0f54ae861b..97a8acd4d301 100644
--- a/dev-libs/atcore/atcore-1.0.0.ebuild
+++ b/dev-libs/atcore/atcore-1.0.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils kde5-functions
+KDE_TEST="forceoptional"
+inherit kde5
DESCRIPTION="API to manage the serial connection between the computer and 3D Printers"
SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
@@ -14,8 +15,11 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="doc gui test"
-RDEPEND="
- $(add_qt_dep qtcore)
+BDEPEND="
+ $(add_qt_dep linguist-tools)
+ doc? ( app-doc/doxygen[dot] )
+"
+DEPEND="
$(add_qt_dep qtserialport)
gui? (
$(add_qt_dep qtcharts)
@@ -23,12 +27,7 @@ RDEPEND="
$(add_qt_dep qtwidgets)
)
"
-DEPEND="${RDEPEND}
- $(add_frameworks_dep extra-cmake-modules)
- $(add_qt_dep linguist-tools)
- doc? ( app-doc/doxygen[dot] )
- test? ( $(add_qt_dep qttest) )
-"
+RDEPEND="${DEPEND}"
src_prepare() {
cmake-utils_src_prepare
@@ -36,10 +35,7 @@ src_prepare() {
sed -e "s/${PN}/${PF}/" -i doc/CMakeLists.txt || die
use gui || punt_bogus_dep Qt5 Charts
- if ! use test; then
- cmake_comment_add_subdirectory unittests
- punt_bogus_dep Qt5 Test
- fi
+ use test || cmake_comment_add_subdirectory unittests
}
src_configure() {