summaryrefslogtreecommitdiff
path: root/dev-libs/apr/apr-1.7.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/apr/apr-1.7.2-r1.ebuild')
-rw-r--r--dev-libs/apr/apr-1.7.2-r1.ebuild35
1 files changed, 6 insertions, 29 deletions
diff --git a/dev-libs/apr/apr-1.7.2-r1.ebuild b/dev-libs/apr/apr-1.7.2-r1.ebuild
index 7986ed4088df..e1c446e9551f 100644
--- a/dev-libs/apr/apr-1.7.2-r1.ebuild
+++ b/dev-libs/apr/apr-1.7.2-r1.ebuild
@@ -31,7 +31,6 @@ BDEPEND="
DOCS=( CHANGES NOTICE README )
PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0-mint.patch
"${FILESDIR}"/${PN}-1.6.3-skip-known-failing-tests.patch
"${FILESDIR}"/${PN}-1.7.2-libtool.patch
"${FILESDIR}"/${PN}-1.7.2-sysroot.patch # bug #385775
@@ -96,38 +95,16 @@ src_configure() {
if use urandom; then
myconf+=( --with-devrandom=/dev/urandom )
- elif (( ${CHOST#*-hpux11.} <= 11 )); then
- : # no /dev/*random on hpux11.11 and before, apr detects this.
else
myconf+=( --with-devrandom=/dev/random )
fi
- # shl_load does not search runpath, but hpux11 supports dlopen
- if [[ ${CHOST} == *-hpux11* ]]; then
- myconf+=( --enable-dso=dlfcn )
- elif [[ ${CHOST} == *-solaris2.10 ]]; then
- local atomic_contents=$(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h)
-
- case "${atomic_contents}" in
- *atomic_cas_ptr*)
- ;;
- *)
- local patch_id=$([[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885)
-
- elog "You do not have Solaris Patch ID ${patch_id} (Problem 4954703) installed on your host ($(hostname)),"
- elog "using generic atomic operations instead."
-
- myconf+=( --disable-nonportable-atomics )
- ;;
- esac
- else
- if use ppc || use sparc || use mips; then
- # Avoid libapr containing undefined references (underlinked)
- # undefined reference to `__sync_val_compare_and_swap_8'
- # (May be possible to fix via libatomic linkage in future?)
- # bug #740464
- myconf+=( --disable-nonportable-atomics )
- fi
+ if use ppc || use sparc || use mips; then
+ # Avoid libapr containing undefined references (underlinked)
+ # undefined reference to `__sync_val_compare_and_swap_8'
+ # (May be possible to fix via libatomic linkage in future?)
+ # bug #740464
+ myconf+=( --disable-nonportable-atomics )
fi
econf "${myconf[@]}"