summaryrefslogtreecommitdiff
path: root/dev-libs/aml/aml-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/aml/aml-9999.ebuild')
-rw-r--r--dev-libs/aml/aml-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
index abe16736f7e8..a7c7dfbf2a1a 100644
--- a/dev-libs/aml/aml-9999.ebuild
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/any1/aml.git"
else
SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~loong ~riscv ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~riscv ~x86"
fi
LICENSE="ISC"
@@ -22,12 +22,16 @@ IUSE="examples"
DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+PATCHES=(
+ "${FILESDIR}"/${P}-queue.patch
+)
+
src_prepare() {
default
- # The bundled copy includes cdefs which breaks on musl and
- # this header is already available on glibc.
- # bug #828806
+ # The bundled copy includes cdefs which breaks on musl and this header is
+ # already available on glibc. See bug #828806 and
+ # https://github.com/any1/aml/issues/11.
rm include/sys/queue.h || die
}