summaryrefslogtreecommitdiff
path: root/dev-lang
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/Manifest.gzbin19354 -> 19353 bytes
-rw-r--r--dev-lang/orc/Manifest2
-rw-r--r--dev-lang/orc/orc-0.4.26-r1.ebuild70
-rw-r--r--dev-lang/php/Manifest6
-rw-r--r--dev-lang/php/php-5.6.33.ebuild2
-rw-r--r--dev-lang/php/php-7.0.27.ebuild2
-rw-r--r--dev-lang/php/php-7.1.13.ebuild2
-rw-r--r--dev-lang/python/Manifest3
-rw-r--r--dev-lang/python/python-3.6.4.ebuild344
9 files changed, 353 insertions, 78 deletions
diff --git a/dev-lang/Manifest.gz b/dev-lang/Manifest.gz
index 52900d715d66..e51f3cbc089f 100644
--- a/dev-lang/Manifest.gz
+++ b/dev-lang/Manifest.gz
Binary files differ
diff --git a/dev-lang/orc/Manifest b/dev-lang/orc/Manifest
index c3985ef5a6bd..f24eb3f882b7 100644
--- a/dev-lang/orc/Manifest
+++ b/dev-lang/orc/Manifest
@@ -1,5 +1,3 @@
-DIST orc-0.4.26.tar.xz 465768 BLAKE2B ad43fb948ccb8e0b3a34a68a14b4baf8541c137643de9f5cf61c2e8e67a1e0cc627f55f00bc7f23c6cb5c8b41fa809aef15ba4a977d4ab29d92549d6c2b8e634 SHA512 c0b02d4f00b7cc45c5952a4db4f63629bbcbc4d338bbe69fd2743198f2b346bf437742a7a8e1d308f765caf1b43f7fab75add7ebf69897bc0e335a169eef7326
DIST orc-0.4.27.tar.xz 465116 BLAKE2B 1289867c84371797350847e1ae71a002ec250abc56611fe6ec8d263ff64e17ed8d990f45adfbf6d1a0c7e98c2e6ec30c3135e433f00e9fa53cecce359f5b2d72 SHA512 5ca0b4553e370ea7c95acfc8248d9d568dafc9577041d47f52c7d0945456c534e18e0e80d28df9301d6deac1ea4f8ea6a51ca373b32927c8724846d8ec1f73e8
-EBUILD orc-0.4.26-r1.ebuild 1832 BLAKE2B e0e0f1df95102719f9f079efdb27760192acb8b3b27232a27984cef94bf03587d16424234d368583200f9e6e4183f7068cd322b55d3d9d559d57d87c5b00d438 SHA512 3a66189a789f995069dc8869fb33846306f4a0e5ff3419bae1e921c26b1187615e17ca6c6f4647eed8e4fc0ab4f5e03a6df0a3dfe762a9090aa409912cfe4497
EBUILD orc-0.4.27.ebuild 1832 BLAKE2B e0e0f1df95102719f9f079efdb27760192acb8b3b27232a27984cef94bf03587d16424234d368583200f9e6e4183f7068cd322b55d3d9d559d57d87c5b00d438 SHA512 3a66189a789f995069dc8869fb33846306f4a0e5ff3419bae1e921c26b1187615e17ca6c6f4647eed8e4fc0ab4f5e03a6df0a3dfe762a9090aa409912cfe4497
MISC metadata.xml 354 BLAKE2B b24bce431d7ad10e9231e89b522e67de16192ee4e48281b8a17f002692632449ab676cb9df6ff5a22563d6f9657ee6be11e452bac41f8a537c598822efab85d1 SHA512 4f17c4c3faa3f2c5feaefe4727b3500360f7cc5486c794e9a34608c3e437b4e2cc266bc9e0e2b3824952a8da62421fda59e9bc5140ee88898f8f7bdde402762f
diff --git a/dev-lang/orc/orc-0.4.26-r1.ebuild b/dev-lang/orc/orc-0.4.26-r1.ebuild
deleted file mode 100644
index abf52976ec57..000000000000
--- a/dev-lang/orc/orc-0.4.26-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic multilib-minimal pax-utils
-
-DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
-HOMEPAGE="https://gstreamer.freedesktop.org/"
-SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="BSD BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 hppa ppc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples pax_kernel static-libs"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- >=dev-util/gtk-doc-am-1.12
-"
-
-src_prepare() {
- default
-
- # Do not build examples
- sed -e '/SUBDIRS/ s:examples::' \
- -i Makefile.am Makefile.in || die
-}
-
-multilib_src_configure() {
- # any optimisation on PPC/Darwin yields in a complaint from the assembler
- # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
- # the same for Intel/Darwin, although the error message there is different
- # but along the same lines
- [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
-
- # FIXME: handle backends per arch ?
- ECONF_SOURCE="${S}" econf \
- --disable-gtk-doc \
- --enable-backend=all \
- $(use_enable static-libs static)
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
- prune_libtool_files --all
-
- if use pax_kernel; then
- pax-mark m "${ED}"usr/bin/orc-bugreport
- pax-mark m "${ED}"usr/bin/orcc
- pax-mark m "${ED}"usr/$(get_libdir)/liborc*.so*
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/{*.c,*.orc}
- fi
-}
-
-pkg_postinst() {
- if use pax_kernel; then
- ewarn "Please run \"revdep-pax\" after installation".
- ewarn "It's provided by sys-apps/elfix."
- fi
-}
diff --git a/dev-lang/php/Manifest b/dev-lang/php/Manifest
index f608526aaa81..8e199dc644d8 100644
--- a/dev-lang/php/Manifest
+++ b/dev-lang/php/Manifest
@@ -13,13 +13,13 @@ DIST php-7.1.13.tar.xz 12194780 BLAKE2B 0bac1cb3ec46cd4206d71b0d8ec3058fff455bc7
DIST php-7.2.0.tar.xz 12014940 BLAKE2B e34c5bfb076e62afc54c8e35e0e35491b803ec753a1e62a0d8e78dd5bb6c28b95a9434228e211b76913f721bd0d8009527c95d2ab7990780819f5d3b8d822c6f SHA512 828d38727edde0dbc6483add6cdc21d33527b887bffaedad2d7f53e25d58a6f661ac341a23db02741bc37248d161aaffd72026dd8ef85ac851594c127d6c0133
DIST php-7.2.1.tar.xz 12094840 BLAKE2B fde1dc143598a74be552eef53d4e7a8cc5a09db67b8d98a4d527e6a7e6a0ad2b9e78429a8981074630c84bb6a95ee2bd8f1a78020062c770abb6fdbdba738cec SHA512 2445f2cff20214b521c48592e5ab42b770c291702178d7cb2a84912c81b7e5d2cc45948a3a4a7830194fa444708d544c73efbaa8e90c95ab77937f7feffb2ffc
EBUILD php-5.6.32.ebuild 22500 BLAKE2B f1e8c507532244ed46c8d995cf847034ebb61abd52a52502c4897d2880e24d62ccf7e6fd843b3ddd1fb225ded90a4edb7f9e728a9313f28ad6b3072ab0eb6950 SHA512 b93ca82892cf15eac9c7d890b96974ea1d00cc224290cd4fe38e85c324231c77033c04667473fc787c173c83fee81d435339a70c155c63f253f28a2dbb7c4bdc
-EBUILD php-5.6.33.ebuild 22542 BLAKE2B e78f9c50ea2cc3423e7c5da86c060fbef67d5fe35da87062dd3d7651cebd0b99d54741140c5ae7b78f0c4cfa52978147e9c8d75b0546aa9a96f76ea8bc8fcc4f SHA512 896cffc8f09ecbe7c55586f2ee9513db95506f970ae60d22a27da187d4964e4a66e34b6398871760609e4b828709f37616f6ebd666f5ef10a7d85a29eb36a938
+EBUILD php-5.6.33.ebuild 22537 BLAKE2B 52e528c790fef79498084ade31d15e586dfc33d3e8fc048ebb9c132830877929f2b61db80372d8b18ee6c28c49250c07d4eb527ea0e58c5137b5697e644c10cc SHA512 1154c2fe968d68170058c615fc8ba985348a9a5b06b9875ec8e12e4dbf15fc898723be2b433cff130e4450f3031f1858c28c1ac10798d1004735b391f945d9ed
EBUILD php-7.0.25.ebuild 21560 BLAKE2B 4898540287e3dd350526f9f13c6e066795dc3ab18ebc5e3278998d897919745efc76a1ee43ee8bddadbb3f570bc1b6779dec6ac055240379ef45c8f70ec61ec3 SHA512 38d1f2d063044db2f4500e99a323f54d992413db26b99926f4d0338190fd481964e1a1573e9ebf06ea315b66d3d1207cd620fcd487745e81739e03c34afe6230
EBUILD php-7.0.26-r1.ebuild 21604 BLAKE2B cc4aa1057b2ba3964684e6cb4844af3619b65f1e59fc4edbe7a3e6994f888e5291b1efcf644bbccf9faa31484eeae3c14b4d3367f53def4b02cffdfe6879c270 SHA512 0ac3f8be4110647b47ba5546a0fb9b0ba1186ac7df664d93ef0687ff695e7dcb6d9a470433f0a3984dc3b019f48017757adf28bd83852387694e8f92ae359fbb
-EBUILD php-7.0.27.ebuild 21604 BLAKE2B cc4aa1057b2ba3964684e6cb4844af3619b65f1e59fc4edbe7a3e6994f888e5291b1efcf644bbccf9faa31484eeae3c14b4d3367f53def4b02cffdfe6879c270 SHA512 0ac3f8be4110647b47ba5546a0fb9b0ba1186ac7df664d93ef0687ff695e7dcb6d9a470433f0a3984dc3b019f48017757adf28bd83852387694e8f92ae359fbb
+EBUILD php-7.0.27.ebuild 21599 BLAKE2B b855401ba63749243ad418edd17701b59ebc70c7713529c2cbff138a5429ac2a7e84039db46a2fa3d0bcaf44791a6f96a4d30482cfe36f23d2f658b592d51c2b SHA512 8ad3f8ac2d63dad59e2a5ccdffa85772075dd8a7ebf0cbd7bfae633df9d8b17bebb1b68034b9ff5571ad34f593f24d98fb2acc9ea4d54a73881b950e50dcfb1c
EBUILD php-7.1.11.ebuild 21443 BLAKE2B a6da3a5efbcae6b3d33d6c40e430137536ecee35d7ad2a2eb47da71041092037edf92f69ab1d642dd5b759619eb37fb1a44425d49284f3230f66cb59e85d968e SHA512 f62a2592c57d0c6641df2ed3388aa3a4fe1097e8f635066b7c3b6070b2e57e10e23f4ded9e3b79cee7876324efd0ca1feab13365eef9848457ca03cc6d7411c2
EBUILD php-7.1.12-r1.ebuild 21470 BLAKE2B bede96eae794b62386e4ae4337e2d25187a716d91c494bf18e0769b3a4d58414729aeaf29955fb25aa0f56dff724f5be3d143901fd9ab02bec8166bba8b4adbe SHA512 ae7a59ce564a5fe30ba63289769842dc8ac58691b4f8ecb6379bd02fac9196d2ba0282cae8527a68b4406de1a0d35de8c2809f84aca502a0e3f925cc26ff2835
-EBUILD php-7.1.13.ebuild 21470 BLAKE2B bede96eae794b62386e4ae4337e2d25187a716d91c494bf18e0769b3a4d58414729aeaf29955fb25aa0f56dff724f5be3d143901fd9ab02bec8166bba8b4adbe SHA512 ae7a59ce564a5fe30ba63289769842dc8ac58691b4f8ecb6379bd02fac9196d2ba0282cae8527a68b4406de1a0d35de8c2809f84aca502a0e3f925cc26ff2835
+EBUILD php-7.1.13.ebuild 21465 BLAKE2B e782e9c971db9b4e02ebac6c9cff0ba12ed5ea8549568cbdc23ea57af9178667e45e6f3f0a6f4617468a59e131cb0db94cecd682aee08b85ebab376b181f295a SHA512 3dc0f1d85ca723f9a63deb7a4598cb443aa608a13e77174aa82a0645d90483751d1786877aceb9d83199491a99b04107bbb622d78cc8ddfd0503e5629cf70a0a
EBUILD php-7.2.0-r1.ebuild 22001 BLAKE2B dec314b3eda1e8f8ddf4ced4ffcc2367ad8c08789408875099a4ed813a155fc1b7ae8a7f1bacde74fa663b108a480440e43e4efc3bf178e278f9238515e3454a SHA512 b3790484ad3141635284db9d01c3290af78a44d93455dcca529d19abeeb111daddc286af10cdf57b79bc0e33a70c27854ae7726bcaa82049ebb69b547798b54b
EBUILD php-7.2.1.ebuild 22001 BLAKE2B dec314b3eda1e8f8ddf4ced4ffcc2367ad8c08789408875099a4ed813a155fc1b7ae8a7f1bacde74fa663b108a480440e43e4efc3bf178e278f9238515e3454a SHA512 b3790484ad3141635284db9d01c3290af78a44d93455dcca529d19abeeb111daddc286af10cdf57b79bc0e33a70c27854ae7726bcaa82049ebb69b547798b54b
MISC metadata.xml 2439 BLAKE2B 7f3cb5f5eab3664c48b951bbf2cdb03b2ce5d119008bbb41dd2c59a34fffbac8c8911738b4988e7e58bf36a520f6c35f46e9383e6845747380109a2f2f3011a6 SHA512 5d0221b77317e021231a2c1ae1dc407dca0e7ad144f5648d9d1abf98434689d375b04c9c45795e38517ca3c3d6077acbe4ff79f3551b20adaeb06325e363ebee
diff --git a/dev-lang/php/php-5.6.33.ebuild b/dev-lang/php/php-5.6.33.ebuild
index 82ff27ece5c1..e92e6e42d3d1 100644
--- a/dev-lang/php/php-5.6.33.ebuild
+++ b/dev-lang/php/php-5.6.33.ebuild
@@ -18,7 +18,7 @@ LICENSE="PHP-3.01
unicode? ( BSD-2 LGPL-2.1 )"
SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
SAPIS="embed cli cgi fpm apache2"
diff --git a/dev-lang/php/php-7.0.27.ebuild b/dev-lang/php/php-7.0.27.ebuild
index dde911b26c69..03d64e1c1b85 100644
--- a/dev-lang/php/php-7.0.27.ebuild
+++ b/dev-lang/php/php-7.0.27.ebuild
@@ -18,7 +18,7 @@ LICENSE="PHP-3.01
unicode? ( BSD-2 LGPL-2.1 )"
SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
SAPIS="embed cli cgi fpm apache2 phpdbg"
diff --git a/dev-lang/php/php-7.1.13.ebuild b/dev-lang/php/php-7.1.13.ebuild
index 5430dc1231b3..7aa65736a04c 100644
--- a/dev-lang/php/php-7.1.13.ebuild
+++ b/dev-lang/php/php-7.1.13.ebuild
@@ -18,7 +18,7 @@ LICENSE="PHP-3.01
unicode? ( BSD-2 LGPL-2.1 )"
SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# We can build the following SAPIs in the given order
SAPIS="embed cli cgi fpm apache2 phpdbg"
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index 26239322deb5..6768d6bfb6f1 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -16,14 +16,17 @@ DIST Python-3.4.5.tar.xz 14516820 BLAKE2B f9ddabd2df2241089d07756d3a8ba1c70096be
DIST Python-3.4.6.tar.xz 14473592 BLAKE2B 4af4f8e6f5c6831b50e99dd9eef47617f14903dc709f53f833c64726b003e9f84f75be80ba8059dcada2b2f262d65875f70d8c53a163546e51f9a715c68f4f20 SHA512 f6785cf6a99a8a27823baefe59cc20e34cbec01bb444c8600e7f49b5437159d5137f9d80fce26e219846d71bfe98f68bc6f0c87719a34db0050a4eaca95959ac
DIST Python-3.5.4.tar.xz 15332320 BLAKE2B 1fc3ba4eb1ed949062961c13fd1f9851c7f9cbeb4916c06a0389349ee2d4872b2b1c2d30138822e6329b6a715f35a66df704b7a04aa4adeb95b685b8d6e45d61 SHA512 dbbe2740ee1cce5404b7b6436a9b3887e15f415a1006efa22014ec7e5b1e48c43eed0ff98f6f5b365c527b8d2525be4ce72bbe404ce71c0835529fcd6f0267ff
DIST Python-3.6.3.tar.xz 16974296 BLAKE2B 8220fc0c2eaa315d3972085b0f531f169adb6cfad57023ad2c115603b5a484573ea3540eb3216edd0f4514256c8edb07469cf38d17727d69cdc15cdf1f601623 SHA512 32f24a3adcb7880003c7ecdc5e53e838e774adda76b308961d8215e28db630b2fa2828097817924c76afa4212b2df3362eb64d4e10f37c0147f512ec5aa8662b
+DIST Python-3.6.4.tar.xz 16992824 BLAKE2B 2347a70bb25468221178b1542ddd4376f136a515f2873ee1f640c4629eb77a9608af0f6be37128ba3e8ad614ebc17e7be20b73384983533aa77bca4403ea7935 SHA512 09ba2103ac517ac4d262f00380c9aac836a53401ce252540c17fd821a3b92e1ddf32528d00772221eb3126b12cb95b62c3ac3e852f4951e6f2eb406c88c848a2
DIST python-gentoo-patches-2.7.14-0.tar.xz 13428 BLAKE2B 0048e48ddaaa4bef08451354fde95a123042880f26dddc9267c7f9a90fd8abb40955e26ee8c9dfc5a1165556bb3e11585b27288e635d42a4000dd3d7654c41ad SHA512 6da5b52065752b54e9215d0f0809c75167dc3690d0e94fa21dd7595626925bc5c1dd065d31b3bd696d7087f3986de145d3a335a29eb7bd77442637a7ec2863c1
DIST python-gentoo-patches-3.4.5-0.tar.xz 12044 BLAKE2B 7fb3cc7dcd987debd5aa263d8e26b21aad439d8e3177c06c3683406a53bbda9652175673b09b6300f6a5b62148190cd8a75c9b65a5de04d770866733fcc0ebcb SHA512 108a4845667ecdf4001fcbeffab0cfbbac87439a449a7351428b0f3e2f159e3848ee0c0dfa45c9fba893b9f9584b33722fc8bb0bd7485a1d0909c3a35ede6ed8
DIST python-gentoo-patches-3.4.6-0.tar.xz 11728 BLAKE2B 2a636f5500f4c7d354f421133f086cba9a25c30d5feaaa2dc25c9c588125d7c9097baecaa11f31548fa598b5dc137ca310ad86222510c0a955fa632a6d0a4b06 SHA512 41c22dc8f1db8800fc0b97eed2b27bf1873e5de1369bd4aecf7a7a91e609a78e45a4b56fc89d575317f33a7704c0c1cad1494e8a993415a198f256e8338f49ab
DIST python-gentoo-patches-3.5.4-0.tar.xz 11704 BLAKE2B 4a7d71feff18c7c8c109bed10748348484d314183c3de3ec950d5ca5ce7048bb322c470f3f5bff2d63eb7f2ed99c0fe75c621df050273d9d118681b28926061d SHA512 d395a87695f700598026038d6929ea5038abd7d494294037a4dfa02d5262203dbbaa6ae258a5a7f35ff5542f6266dcf69cc0b9c3df2a047cd2f6699a87e182ec
DIST python-gentoo-patches-3.6.2-0.tar.xz 10744 BLAKE2B 3075754627617ac2ceee879eaf1a0e6564505655cdbdff380233a09df701a6188d64fe1f6a8c642b1fb05ef3c460a07042b6a362d655cd02717d6d9ba47983a1 SHA512 2aac1700c541202aa4f43bff4cb521b996d52ab350133318abaddb43f4b6e20548f37de472ace8024ef325ebf63fdfff0d43f8aa1f717d3c56f974b7aa1764e3
+DIST python-gentoo-patches-3.6.4.tar.xz 12888 BLAKE2B 7cf49ae22df53e855f2e99df51686b5d4bd0da82ef4c22836e24726ea9ed561808352c0305a5659b052d38b843f1ff61b6466a7bc3673b7e5cfb4d81d22fa4bc SHA512 90a1b685f2539872ffd67f96581f70145b7afaf18af19f4a7f4a61214103d2a10bf0069c1769dac229ae011fceaf8538f041082b33c1671905246d018d184dd7
EBUILD python-2.7.14-r1.ebuild 10796 BLAKE2B 705db175a906c0087f462d4b7ed94ebfbf87acc5624d573860594ede1eea486ed65ff74967a64f24794e8f9efa85b27f9d74356bb069b82aaac47d906aa45b84 SHA512 d2dabd2997c85b26d82bebe4c9f3a24cf677cb3e0fd63c0a6896a3c29e73fec66f34eecdecddeb37264e51c3c379ddead561b4aef82f66b91289b8dc45c1402f
EBUILD python-3.4.5-r1.ebuild 10591 BLAKE2B 72555298d0241e84f95d2fd2aa169f59b8fba25c5118bcbb2b8183c44cdb27e2dbbc98d8371cebe3ed30c6b5eb5706e4acb6c184d66efddcea1e71ff1187be81 SHA512 75bb75e86b32418c6587a327faa5ad1be7eb7cb35346a9af203ad5d2e4aa602bb7e09b3daac1efd94d573a18d80c90681f0a6628c731921288739664fcf86485
EBUILD python-3.4.6-r1.ebuild 10604 BLAKE2B cea6146a6b8643d1ba8def78647a83ee25bb055b9605c0f3d214220500034c7a412955fa8047a058e383dbcb832ddd1300ee2ff7a05b37d7dc7fa831d6631c5b SHA512 4aea9eed7fa7806d5eb8f51253c9665b6b887ed187db39959a42a99da2e4ef259109c1442886156019790b8f83c4a63dfb9e5ff33df318a9ec75521d02336359
EBUILD python-3.5.4-r1.ebuild 10656 BLAKE2B 1c1c05f3c185f7390630e1eaaf2a44625c020875d6ae6da50e1741f3fcd2e387ec200bd4025bb7f44477e2f5fb2157b40a367f8f06ae2e2a92c3b17324dd8ab6 SHA512 1e4daf79ec691dac6b0ee57bfdf8f8e693f73d268b81068aeabf2b601a7cd22b315b8305f8aa35fda008903846c1bbd8894149d6b837571945248fe7013bb4eb
EBUILD python-3.6.3-r1.ebuild 10089 BLAKE2B 110ebced7001de998877ddc0b6e2fbd65b720d77ed36ae11904011a77dd06c8e02cc40e15c70814fbad86102d2a97434f6f4d38809c1f476b8fb0e9fdcbbb460 SHA512 52fd7f2859179c6134674969fb485b4c020a87a2764b9b0ebd290ca007d85c13b169e71d2272660b532b8cd28b849ba7c647bc16d1e6814a4856e796959c32ae
+EBUILD python-3.6.4.ebuild 10016 BLAKE2B 5c8881506820cda98c9fd8428f94523007cea53502107d1664fb3f500571c4ce54084f477951948c5e8000d72467265f6f27190801707613790106bac71c7390 SHA512 9ff794f871015bb03dc5db8a5d1ee5d25c3d425d396a7470e6ea32d69a52914852aa3a8ca6d15135dad049d7cca7cee157ca1de152d44274e7fc45f3f9ae140e
MISC metadata.xml 738 BLAKE2B 464af9b051fa52c8d7f632163a0ea51e356f79d5f0a2ba82c8ac70ef2ebf5ea489bb0d5371ebd954ee0d5b07fc86b8497be3aa2f660929eb09c4a0222a6cf704 SHA512 f938683740658db5d8eb363bf0eb88a81aab75b7a9e4c5e33bca73722c3b1a8b879151bda58099d67c5596a7dd5d487f15b0f7327918e35ac997e15feaf89847
diff --git a/dev-lang/python/python-3.6.4.ebuild b/dev-lang/python/python-3.6.4.ebuild
new file mode 100644
index 000000000000..bf6b9a5fb09e
--- /dev/null
+++ b/dev-lang/python/python-3.6.4.ebuild
@@ -0,0 +1,344 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+WANT_LIBTOOL="none"
+
+inherit autotools flag-o-matic pax-utils python-utils-r1 toolchain-funcs
+
+MY_P="Python-${PV}"
+PATCHSET_VERSION="3.6.4"
+
+DESCRIPTION="An interpreted, interactive, object-oriented programming language"
+HOMEPAGE="https://www.python.org/"
+SRC_URI="https://www.python.org/ftp/python/${PV}/${MY_P}.tar.xz
+ https://dev.gentoo.org/~floppym/python/python-gentoo-patches-${PATCHSET_VERSION}.tar.xz"
+
+LICENSE="PSF-2"
+SLOT="3.6/3.6m"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl +threads tk wininst +xml"
+
+# Do not add a dependency on dev-lang/python to this ebuild.
+# If you need to apply a patch which requires python for bootstrapping, please
+# run the bootstrap code on your dev box and include the results in the
+# patchset. See bug 447752.
+
+RDEPEND="app-arch/bzip2:0=
+ app-arch/xz-utils:0=
+ >=sys-libs/zlib-1.1.3:0=
+ virtual/libffi
+ virtual/libintl
+ gdbm? ( sys-libs/gdbm:0=[berkdb] )
+ ncurses? (
+ >=sys-libs/ncurses-5.2:0=
+ readline? ( >=sys-libs/readline-4.1:0= )
+ )
+ sqlite? ( >=dev-db/sqlite-3.3.8:3= )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ tk? (
+ >=dev-lang/tcl-8.0:0=
+ >=dev-lang/tk-8.0:0=
+ dev-tcltk/blt:0=
+ dev-tcltk/tix
+ )
+ xml? ( >=dev-libs/expat-2.1:0= )
+ !!<sys-apps/sandbox-2.6-r1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ !sys-devel/gcc[libffi(-)]"
+RDEPEND+=" !build? ( app-misc/mime-types )"
+PDEPEND=">=app-eselect/eselect-python-20140125-r1"
+
+S="${WORKDIR}/${MY_P}"
+PYVER=${SLOT%/*}
+
+src_prepare() {
+ # Ensure that internal copies of expat, libffi and zlib are not used.
+ rm -fr Modules/expat
+ rm -fr Modules/_ctypes/libffi*
+ rm -fr Modules/zlib
+
+ local PATCHES=(
+ "${WORKDIR}/patches"
+ "${FILESDIR}/${PN}-3.5-distutils-OO-build.patch"
+ "${FILESDIR}/3.6-disable-nis.patch"
+ )
+
+ default
+
+ sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
+ Lib/distutils/command/install.py \
+ Lib/distutils/sysconfig.py \
+ Lib/site.py \
+ Lib/sysconfig.py \
+ Lib/test/test_site.py \
+ Makefile.pre.in \
+ Modules/Setup.dist \
+ Modules/getpath.c \
+ configure.ac \
+ setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
+
+ eautoreconf
+}
+
+src_configure() {
+ local disable
+ use gdbm || disable+=" gdbm"
+ use ncurses || disable+=" _curses _curses_panel"
+ use readline || disable+=" readline"
+ use sqlite || disable+=" _sqlite3"
+ use ssl || export PYTHON_DISABLE_SSL="1"
+ use tk || disable+=" _tkinter"
+ use xml || disable+=" _elementtree pyexpat" # _elementtree uses pyexpat.
+ export PYTHON_DISABLE_MODULES="${disable}"
+
+ if ! use xml; then
+ ewarn "You have configured Python without XML support."
+ ewarn "This is NOT a recommended configuration as you"
+ ewarn "may face problems parsing any XML documents."
+ fi
+
+ if [[ -n "${PYTHON_DISABLE_MODULES}" ]]; then
+ einfo "Disabled modules: ${PYTHON_DISABLE_MODULES}"
+ fi
+
+ if [[ "$(gcc-major-version)" -ge 4 ]]; then
+ append-flags -fwrapv
+ fi
+
+ filter-flags -malign-double
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=50309
+ if is-flagq -O3; then
+ is-flagq -fstack-protector-all && replace-flags -O3 -O2
+ use hardened && replace-flags -O3 -O2
+ fi
+
+ # Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
+ tc-export CXX
+
+ # Set LDFLAGS so we link modules with -lpython3.2 correctly.
+ # Needed on FreeBSD unless Python 3.2 is already installed.
+ # Please query BSD team before removing this!
+ append-ldflags "-L."
+
+ local dbmliborder
+ if use gdbm; then
+ dbmliborder+="${dbmliborder:+:}gdbm"
+ fi
+
+ local myeconfargs=(
+ --with-fpectl
+ --enable-shared
+ $(use_enable ipv6)
+ $(use_with threads)
+ --infodir='${prefix}/share/info'
+ --mandir='${prefix}/share/man'
+ --with-computed-gotos
+ --with-dbmliborder="${dbmliborder}"
+ --with-libc=
+ --enable-loadable-sqlite-extensions
+ --without-ensurepip
+ --with-system-expat
+ --with-system-ffi
+ )
+
+ OPT="" econf "${myeconfargs[@]}"
+
+ if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
+}
+
+src_compile() {
+ # Ensure sed works as expected
+ # https://bugs.gentoo.org/594768
+ local -x LC_ALL=C
+
+ emake CPPFLAGS= CFLAGS= LDFLAGS=
+
+ # Work around bug 329499. See also bug 413751 and 457194.
+ if has_version dev-libs/libffi[pax_kernel]; then
+ pax-mark E python
+ else
+ pax-mark m python
+ fi
+}
+
+src_test() {
+ # Tests will not work when cross compiling.
+ if tc-is-cross-compiler; then
+ elog "Disabling tests due to crosscompiling."
+ return
+ fi
+
+ # Skip failing tests.
+ local skipped_tests="gdb"
+
+ for test in ${skipped_tests}; do
+ mv "${S}"/Lib/test/test_${test}.py "${T}"
+ done
+
+ local -x PYTHONDONTWRITEBYTECODE=
+
+ emake test EXTRATESTOPTS="-u-network" CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
+ local result=$?
+
+ for test in ${skipped_tests}; do
+ mv "${T}/test_${test}.py" "${S}"/Lib/test
+ done
+
+ elog "The following tests have been skipped:"
+ for test in ${skipped_tests}; do
+ elog "test_${test}.py"
+ done
+
+ elog "If you would like to run them, you may:"
+ elog "cd '${EPREFIX}/usr/$(get_libdir)/python${PYVER}/test'"
+ elog "and run the tests separately."
+
+ if [[ ${result} -ne 0 ]]; then
+ die "emake test failed"
+ fi
+}
+
+src_install() {
+ local libdir=${ED}/usr/$(get_libdir)/python${PYVER}
+
+ emake DESTDIR="${D}" altinstall
+
+ sed \
+ -e "s/\(CONFIGURE_LDFLAGS=\).*/\1/" \
+ -e "s/\(PY_LDFLAGS=\).*/\1/" \
+ -i "${libdir}/config-${PYVER}"*/Makefile || die "sed failed"
+
+ # Fix collisions between different slots of Python.
+ rm -f "${ED}usr/$(get_libdir)/libpython3.so"
+
+ # Cheap hack to get version with ABIFLAGS
+ local abiver=$(cd "${ED}usr/include"; echo python*)
+ if [[ ${abiver} != python${PYVER} ]]; then
+ # Replace python3.X with a symlink to python3.Xm
+ rm "${ED}usr/bin/python${PYVER}" || die
+ dosym "${abiver}" "/usr/bin/python${PYVER}"
+ # Create python3.X-config symlink
+ dosym "${abiver}-config" "/usr/bin/python${PYVER}-config"
+ # Create python-3.5m.pc symlink
+ dosym "python-${PYVER}.pc" "/usr/$(get_libdir)/pkgconfig/${abiver/${PYVER}/-${PYVER}}.pc"
+ fi
+
+ # python seems to get rebuilt in src_install (bug 569908)
+ # Work around it for now.
+ if has_version dev-libs/libffi[pax_kernel]; then
+ pax-mark E "${ED}usr/bin/${abiver}"
+ else
+ pax-mark m "${ED}usr/bin/${abiver}"
+ fi
+
+ use sqlite || rm -r "${libdir}/"{sqlite3,test/test_sqlite*} || die
+ use tk || rm -r "${ED}usr/bin/idle${PYVER}" "${libdir}/"{idlelib,tkinter,test/test_tk*} || die
+
+ use threads || rm -r "${libdir}/multiprocessing" || die
+ use wininst || rm "${libdir}/distutils/command/"wininst-*.exe || die
+
+ dodoc "${S}"/Misc/{ACKS,HISTORY,NEWS}
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ find "${S}"/Tools -name __pycache__ -print0 | xargs -0 rm -fr
+ doins -r "${S}"/Tools
+ fi
+ insinto /usr/share/gdb/auto-load/usr/$(get_libdir) #443510
+ local libname=$(printf 'e:\n\t@echo $(INSTSONAME)\ninclude Makefile\n' | \
+ emake --no-print-directory -s -f - 2>/dev/null)
+ newins "${S}"/Tools/gdb/libpython.py "${libname}"-gdb.py
+
+ newconfd "${FILESDIR}/pydoc.conf" pydoc-${PYVER}
+ newinitd "${FILESDIR}/pydoc.init" pydoc-${PYVER}
+ sed \
+ -e "s:@PYDOC_PORT_VARIABLE@:PYDOC${PYVER/./_}_PORT:" \
+ -e "s:@PYDOC@:pydoc${PYVER}:" \
+ -i "${ED}etc/conf.d/pydoc-${PYVER}" "${ED}etc/init.d/pydoc-${PYVER}" || die "sed failed"
+
+ # for python-exec
+ local vars=( EPYTHON PYTHON_SITEDIR PYTHON_SCRIPTDIR )
+
+ # if not using a cross-compiler, use the fresh binary
+ if ! tc-is-cross-compiler; then
+ local -x PYTHON=./python
+ local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}${PWD}
+ else
+ vars=( PYTHON "${vars[@]}" )
+ fi
+
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
+ python_domodule epython.py
+
+ # python-exec wrapping support
+ local pymajor=${PYVER%.*}
+ mkdir -p "${D}${PYTHON_SCRIPTDIR}" || die
+ # python and pythonX
+ ln -s "../../../bin/${abiver}" \
+ "${D}${PYTHON_SCRIPTDIR}/python${pymajor}" || die
+ ln -s "python${pymajor}" \
+ "${D}${PYTHON_SCRIPTDIR}/python" || die
+ # python-config and pythonX-config
+ # note: we need to create a wrapper rather than symlinking it due
+ # to some random dirname(argv[0]) magic performed by python-config
+ cat > "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" <<-EOF || die
+ #!/bin/sh
+ exec "${abiver}-config" "\${@}"
+ EOF
+ chmod +x "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" || die
+ ln -s "python${pymajor}-config" \
+ "${D}${PYTHON_SCRIPTDIR}/python-config" || die
+ # 2to3, pydoc, pyvenv
+ ln -s "../../../bin/2to3-${PYVER}" \
+ "${D}${PYTHON_SCRIPTDIR}/2to3" || die
+ ln -s "../../../bin/pydoc${PYVER}" \
+ "${D}${PYTHON_SCRIPTDIR}/pydoc" || die
+ ln -s "../../../bin/pyvenv-${PYVER}" \
+ "${D}${PYTHON_SCRIPTDIR}/pyvenv" || die
+ # idle
+ if use tk; then
+ ln -s "../../../bin/idle${PYVER}" \
+ "${D}${PYTHON_SCRIPTDIR}/idle" || die
+ fi
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-${PYVER}" && ! has_version ">=${CATEGORY}/${PN}-${PYVER}_alpha"; then
+ python_updater_warning="1"
+ fi
+}
+
+eselect_python_update() {
+ if [[ -z "$(eselect python show)" || ! -f "${EROOT}usr/bin/$(eselect python show)" ]]; then
+ eselect python update
+ fi
+
+ if [[ -z "$(eselect python show --python${PV%%.*})" || ! -f "${EROOT}usr/bin/$(eselect python show --python${PV%%.*})" ]]; then
+ eselect python update --python${PV%%.*}
+ fi
+}
+
+pkg_postinst() {
+ eselect_python_update
+
+ if [[ "${python_updater_warning}" == "1" ]]; then
+ ewarn "You have just upgraded from an older version of Python."
+ ewarn
+ ewarn "Please adjust PYTHON_TARGETS (if so desired), and run emerge with the --newuse or --changed-use option to rebuild packages installing python modules."
+ fi
+}
+
+pkg_postrm() {
+ eselect_python_update
+}