summaryrefslogtreecommitdiff
path: root/dev-lang/vala/vala-0.56.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/vala/vala-0.56.16.ebuild')
-rw-r--r--dev-lang/vala/vala-0.56.16.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lang/vala/vala-0.56.16.ebuild b/dev-lang/vala/vala-0.56.16.ebuild
new file mode 100644
index 000000000000..ec0273524b5a
--- /dev/null
+++ b/dev-lang/vala/vala-0.56.16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Compiler for the GObject type system"
+HOMEPAGE="https://wiki.gnome.org/Projects/Vala https://gitlab.gnome.org/GNOME/vala"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.56"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="test valadoc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.48.0:2
+ >=dev-libs/vala-common-${PV}
+ valadoc? ( >=media-gfx/graphviz-2.16 )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2
+ dev-libs/gobject-introspection
+ )
+"
+BDEPEND="
+ dev-libs/libxslt
+ app-alternatives/lex
+ virtual/pkgconfig
+ app-alternatives/yacc
+"
+
+src_configure() {
+ # weasyprint enables generation of PDF from HTML
+ gnome2_src_configure \
+ --disable-unversioned \
+ $(use_enable valadoc) \
+ VALAC=: \
+ WEASYPRINT=:
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}