summaryrefslogtreecommitdiff
path: root/dev-lang/spidermonkey/spidermonkey-91.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/spidermonkey/spidermonkey-91.13.0.ebuild')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-91.13.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-91.13.0.ebuild b/dev-lang/spidermonkey/spidermonkey-91.13.0.ebuild
index 6dc4ab9f813f..11f4cc2fe5e8 100644
--- a/dev-lang/spidermonkey/spidermonkey-91.13.0.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-91.13.0.ebuild
@@ -120,8 +120,8 @@ llvm_check_deps() {
fi
if use lto ; then
- if ! has_version -b "=sys-devel/lld-${LLVM_SLOT}*" ; then
- einfo "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ if ! has_version -b "sys-devel/lld:${LLVM_SLOT}" ; then
+ einfo "sys-devel/lld:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
fi
@@ -235,10 +235,12 @@ src_configure() {
einfo "Current RUSTFLAGS: ${RUSTFLAGS}"
local have_switched_compiler=
- if use clang && ! tc-is-clang ; then
+ if use clang; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
- have_switched_compiler=yes
+ if tc-is-gcc; then
+ have_switched_compiler=yes
+ fi
AR=llvm-ar
CC=${CHOST}-clang
CXX=${CHOST}-clang++