summaryrefslogtreecommitdiff
path: root/dev-lang/solidity/solidity-0.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/solidity/solidity-0.4.2.ebuild')
-rw-r--r--dev-lang/solidity/solidity-0.4.2.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-lang/solidity/solidity-0.4.2.ebuild b/dev-lang/solidity/solidity-0.4.2.ebuild
deleted file mode 100644
index 7deebb0fb767..000000000000
--- a/dev-lang/solidity/solidity-0.4.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="The Solidity Contract-Oriented Programming Language"
-HOMEPAGE="https://github.com/ethereum/solidity"
-SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-libs/jsoncpp:=
- dev-libs/boost:=
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # The build won't work without this file but it is missing from
- # the release tarball.
- #
- # Reported upstream: https://github.com/ethereum/solidity/issues/1183
-
- cp "${FILESDIR}"/${P}-commit_hash.txt "${S}"/commit_hash.txt || die "Could not copy commit hash"
-
- # Without this file the build is marked as a developer version
- # but it is missing from the release tarball.
- #
- # Reported upstream: https://github.com/ethereum/solidity/issues/1183
-
- touch "${S}"/prerelease.txt || die "Could not mark as release version"
-}