summaryrefslogtreecommitdiff
path: root/dev-lang/rust/rust-1.32.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.32.0.ebuild')
-rw-r--r--dev-lang/rust/rust-1.32.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-lang/rust/rust-1.32.0.ebuild b/dev-lang/rust/rust-1.32.0.ebuild
index 06578ddc8bfd..8a1990cfb627 100644
--- a/dev-lang/rust/rust-1.32.0.ebuild
+++ b/dev-lang/rust/rust-1.32.0.ebuild
@@ -40,8 +40,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="clippy cpu_flags_x86_sse2 debug doc libressl rls rustfmt system-llvm wasm ${ALL_LLVM_TARGETS[*]}"
-COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
- sys-libs/zlib
+COMMON_DEPEND="sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
net-libs/libssh2
@@ -56,6 +55,7 @@ DEPEND="${COMMON_DEPEND}
)
dev-util/cmake"
RDEPEND="${COMMON_DEPEND}
+ >=app-eselect/eselect-rust-20190311
!dev-util/cargo
rustfmt? ( !dev-util/rustfmt )"
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
@@ -107,6 +107,12 @@ src_prepare() {
"${WORKDIR}/${rust_stage0}"/install.sh --disable-ldconfig --destdir="${rust_stage0_root}" --prefix=/ || die
+ # ugly hack for https://bugs.gentoo.org/679806
+ if use ppc64; then
+ sed -i 's/getentropy/gEtEnTrOpY/g' "${rust_stage0_root}"/bin/cargo || die
+ export OPENSSL_ppccap=0
+ fi
+
default
}