summaryrefslogtreecommitdiff
path: root/dev-lang/rust/rust-1.29.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.29.1-r1.ebuild')
-rw-r--r--dev-lang/rust/rust-1.29.1-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/rust/rust-1.29.1-r1.ebuild b/dev-lang/rust/rust-1.29.1-r1.ebuild
index 7e2cf6102204..a1262c26086d 100644
--- a/dev-lang/rust/rust-1.29.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.29.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -50,8 +50,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="cargo clippy cpu_flags_x86_sse2 debug doc +jemalloc libressl rls rustfmt wasm ${ALL_LLVM_TARGETS[*]}"
-COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
- jemalloc? ( dev-libs/jemalloc )
+COMMON_DEPEND="jemalloc? ( dev-libs/jemalloc )
cargo? (
sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
@@ -68,6 +67,7 @@ DEPEND="${COMMON_DEPEND}
)
dev-util/cmake"
RDEPEND="${COMMON_DEPEND}
+ >=app-eselect/eselect-rust-0.3_pre20150425
cargo? ( !dev-util/cargo )
rustfmt? ( !dev-util/rustfmt )"
PDEPEND="!cargo? ( >=dev-util/cargo-${CARGO_DEPEND_VERSION} )"