summaryrefslogtreecommitdiff
path: root/dev-lang/rust-bin/rust-bin-1.29.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust-bin/rust-bin-1.29.1.ebuild')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.29.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.29.1.ebuild b/dev-lang/rust-bin/rust-bin-1.29.1.ebuild
index 857b9fca3135..509e6014d003 100644
--- a/dev-lang/rust-bin/rust-bin-1.29.1.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.29.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,8 +20,8 @@ SRC_URI="amd64? ( https://static.rust-lang.org/dist/${MY_P}-x86_64-unknown-linux
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="cargo clippy doc libressl rustfmt"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="cargo clippy cpu_flags_x86_sse2 doc libressl rustfmt"
CARGO_DEPEND_VERSION="0.$(($(get_version_component_range 2) + 1)).0"
@@ -36,10 +36,10 @@ RDEPEND="${DEPEND}
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
net-libs/libssh2
- net-libs/http-parser:=
net-misc/curl[ssl]
)"
PDEPEND="!cargo? ( >=dev-util/cargo-${CARGO_DEPEND_VERSION} )"
+REQUIRED_USE="x86? ( cpu_flags_x86_sse2 )"
QA_PREBUILT="
opt/${P}/bin/*-${PV}