summaryrefslogtreecommitdiff
path: root/dev-lang/ruby/files/2.7/002-autoconf-2.70.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ruby/files/2.7/002-autoconf-2.70.patch')
-rw-r--r--dev-lang/ruby/files/2.7/002-autoconf-2.70.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lang/ruby/files/2.7/002-autoconf-2.70.patch b/dev-lang/ruby/files/2.7/002-autoconf-2.70.patch
new file mode 100644
index 000000000000..bea2bc178dc4
--- /dev/null
+++ b/dev-lang/ruby/files/2.7/002-autoconf-2.70.patch
@@ -0,0 +1,26 @@
+diff --git a/configure.ac b/configure.ac
+index 6766df2..bc503d6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -177,13 +177,14 @@ AS_CASE(["$host_os:$build_os"],
+ # clang version 1.0 (http://llvm.org/svn/llvm-project/cfe/tags/Apple/clang-23 exported)
+ # Apple clang version 2.0 (tags/Apple/clang-137) (based on LLVM 2.9svn)
+ # Apple clang version 2.1 (tags/Apple/clang-163.7.1) (based on LLVM 3.0svn)
+- AS_IF([! $CC -E -xc - <<SRC >/dev/null], [
+- @%:@if defined __APPLE_CC__ && defined __clang_major__ && __clang_major__ < 3
+- @%:@error premature clang
+- @%:@endif
+-SRC
+- AC_MSG_ERROR([clang version 3.0 or later is required])
+- ])],
++ AC_PREPROC_IFELSE(
++ [AC_LANG_PROGRAM([
++ @%:@if defined __APPLE_CC__ && defined __clang_major__ && __clang_major__ < 3
++ @%:@error premature clang
++ @%:@endif
++ ])],
++ [],
++ [AC_MSG_ERROR([clang version 3.0 or later is required])])],
+ [openbsd*:openbsd*], [
+ AC_CHECK_TOOLS(CC, [cc])
+ ])