summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.9.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.9.16.ebuild')
-rw-r--r--dev-lang/python/python-3.9.16.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.9.16.ebuild b/dev-lang/python/python-3.9.16.ebuild
index e6b279292564..f6dbbd4312df 100644
--- a/dev-lang/python/python-3.9.16.ebuild
+++ b/dev-lang/python/python-3.9.16.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
WANT_LIBTOOL="none"
inherit autotools check-reqs flag-o-matic multiprocessing pax-utils
-inherit python-utils-r1 toolchain-funcs verify-sig
+inherit prefix python-utils-r1 toolchain-funcs verify-sig
MY_PV=${PV/_rc/rc}
MY_P="Python-${MY_PV%_p*}"
@@ -293,6 +293,7 @@ src_configure() {
append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
fi
+ hprefixify setup.py
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then