summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.8.15_p3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.8.15_p3.ebuild')
-rw-r--r--dev-lang/python/python-3.8.15_p3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.8.15_p3.ebuild b/dev-lang/python/python-3.8.15_p3.ebuild
index d2a1816f893b..1c522eb3b332 100644
--- a/dev-lang/python/python-3.8.15_p3.ebuild
+++ b/dev-lang/python/python-3.8.15_p3.ebuild
@@ -31,7 +31,7 @@ SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
bluetooth build +ensurepip examples gdbm hardened lto +ncurses pgo
- +readline +sqlite +ssl test tk wininst +xml
+ +readline +sqlite +ssl test tk valgrind wininst +xml
"
RESTRICT="!test? ( test )"
@@ -68,6 +68,7 @@ DEPEND="
${RDEPEND}
bluetooth? ( net-wireless/bluez )
test? ( app-arch/xz-utils[extra-filters(+)] )
+ valgrind? ( dev-util/valgrind )
"
# autoconf-archive needed to eautoreconf
BDEPEND="
@@ -175,6 +176,8 @@ src_configure() {
--with-system-expat
--with-system-ffi
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+
+ $(use_with valgrind)
)
# disable implicit optimization/debugging flags