summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.7.3.ebuild')
-rw-r--r--dev-lang/python/python-3.7.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.7.3.ebuild b/dev-lang/python/python-3.7.3.ebuild
index afdbc6cebb11..723abdc211b4 100644
--- a/dev-lang/python/python-3.7.3.ebuild
+++ b/dev-lang/python/python-3.7.3.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://www.python.org/ftp/python/${PV}/${MY_P}.tar.xz
LICENSE="PSF-2"
SLOT="3.7/3.7m"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
@@ -120,6 +120,9 @@ src_configure() {
# Please query BSD team before removing this!
append-ldflags "-L."
+ # Fix implicit declarations on cross and prefix builds. Bug #674070.
+ use ncurses && append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
+
local dbmliborder
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"