summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.4.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.4.6.ebuild')
-rw-r--r--dev-lang/python/python-3.4.6.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.4.6.ebuild b/dev-lang/python/python-3.4.6.ebuild
index f5d3c43753b3..4e06debaade7 100644
--- a/dev-lang/python/python-3.4.6.ebuild
+++ b/dev-lang/python/python-3.4.6.ebuild
@@ -72,6 +72,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
epatch "${FILESDIR}/${PN}-3.4.3-ncurses-pkg-config.patch"
epatch "${FILESDIR}/${PN}-3.4.5-cross.patch"
+ epatch "${FILESDIR}/3.4-getentropy-linux.patch"
epatch_user
@@ -284,7 +285,7 @@ src_install() {
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
local -x PYTHON=./python
- local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}${PWD}
else
vars=( PYTHON "${vars[@]}" )
fi