summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.10.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.10.9.ebuild')
-rw-r--r--dev-lang/python/python-3.10.9.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.10.9.ebuild b/dev-lang/python/python-3.10.9.ebuild
index bb4dfcde3ea3..1b3700f2b2b9 100644
--- a/dev-lang/python/python-3.10.9.ebuild
+++ b/dev-lang/python/python-3.10.9.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
WANT_LIBTOOL="none"
inherit autotools check-reqs flag-o-matic multiprocessing pax-utils
-inherit python-utils-r1 toolchain-funcs verify-sig
+inherit prefix python-utils-r1 toolchain-funcs verify-sig
MY_PV=${PV/_rc/rc}
MY_P="Python-${MY_PV%_p*}"
@@ -299,6 +299,7 @@ src_configure() {
append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
fi
+ hprefixify setup.py
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then