summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.10.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.10.13.ebuild')
-rw-r--r--dev-lang/python/python-3.10.13.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-lang/python/python-3.10.13.ebuild b/dev-lang/python/python-3.10.13.ebuild
index a147169c4d1f..be5cdcb2af4f 100644
--- a/dev-lang/python/python-3.10.13.ebuild
+++ b/dev-lang/python/python-3.10.13.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
- bluetooth build debug +ensurepip examples gdbm libedit lto
+ bluetooth build debug +ensurepip examples gdbm libedit
+ncurses pgo +readline +sqlite +ssl test tk valgrind +xml
"
RESTRICT="!test? ( test )"
@@ -223,11 +223,6 @@ src_configure() {
append-flags -fwrapv
filter-flags -malign-double
- # https://bugs.gentoo.org/700012
- if is-flagq -flto || is-flagq '-flto=*'; then
- append-cflags $(test-flags-CC -ffat-lto-objects)
- fi
-
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
# PKG_CONFIG needed for cross.
tc-export CXX PKG_CONFIG
@@ -291,12 +286,12 @@ src_configure() {
--with-libc=
--enable-loadable-sqlite-extensions
--without-ensurepip
+ --without-lto
--with-system-expat
--with-system-ffi
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
$(use_with debug assertions)
- $(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
$(use_with valgrind)
@@ -305,6 +300,14 @@ src_configure() {
# disable implicit optimization/debugging flags
local -x OPT=
+ # https://bugs.gentoo.org/700012
+ if tc-is-lto; then
+ append-cflags $(test-flags-CC -ffat-lto-objects)
+ myeconfargs+=(
+ --with-lto
+ )
+ fi
+
if tc-is-cross-compiler ; then
build_cbuild_python
# Point the imminent CHOST build to the Python we just