summaryrefslogtreecommitdiff
path: root/dev-lang/python-exec/python-exec-2.4.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python-exec/python-exec-2.4.10.ebuild')
-rw-r--r--dev-lang/python-exec/python-exec-2.4.10.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-lang/python-exec/python-exec-2.4.10.ebuild b/dev-lang/python-exec/python-exec-2.4.10.ebuild
index 05556b1b0d4e..85085af14303 100644
--- a/dev-lang/python-exec/python-exec-2.4.10.ebuild
+++ b/dev-lang/python-exec/python-exec-2.4.10.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit python-any-r1
DESCRIPTION="Python script wrapper"
@@ -19,11 +20,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-lang/python-exec-conf
- !<=dev-lang/python-2.7.18-r3:2.7"
+ !<=dev-lang/python-2.7.18-r3:2.7
+"
BDEPEND="
test? (
$(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
- )"
+ )
+"
python_check_deps() {
python_has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
@@ -50,6 +53,11 @@ src_configure() {
econf "${myconf[@]}"
}
+src_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ default
+}
+
src_install() {
default