summaryrefslogtreecommitdiff
path: root/dev-lang/php
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/Manifest2
-rw-r--r--dev-lang/php/php-8.3.3-r1.ebuild (renamed from dev-lang/php/php-8.3.3.ebuild)25
2 files changed, 8 insertions, 19 deletions
diff --git a/dev-lang/php/Manifest b/dev-lang/php/Manifest
index cc08aa744d57..4e67b9baca3f 100644
--- a/dev-lang/php/Manifest
+++ b/dev-lang/php/Manifest
@@ -15,5 +15,5 @@ EBUILD php-8.1.26-r1.ebuild 21992 BLAKE2B 6a2d19aefc689f44603bf95a14b21e345ae739
EBUILD php-8.1.27-r2.ebuild 22481 BLAKE2B c676a47d00bfe59a69272f5a4cc5dba1a95c778353777f666d20cdf9f998cf90122978aa98a6739e24879f0d778645e8a15123308f79240aaa69fecb6cf262cc SHA512 86e7528fa4a7f6bf698b960bdda0a0db0439d50c3bb44d756940a41f43a747259d1dd6b51206b86f72296d86955721ad69c0cecd8a284bea43c5d282767d8c67
EBUILD php-8.2.15.ebuild 25068 BLAKE2B d5cbab3d9abcddd66811cfc7b023870c414a87d0b5f5597006f0b224661ce1424699f6eaf9c83e18377ea43cd38f3baf0d47403225a5fbaa862c57238801a601 SHA512 4d30ea5da9b2b8003723d7b93db2030422693ade3f4817c69002d05ee436e890a9bbfdae9f4a5221361520352870454e3de6a76a592c364fa27c85665b3734c1
EBUILD php-8.2.16-r1.ebuild 25342 BLAKE2B 98557ae46d32c56661ea895a45280cb6982f09775726500f395e88204a417042dbf27b4b6392ef185200588be6a92eefeaa689c6546ee56f81a552ebb822107e SHA512 741725821c9bf40edadf676745c3eca5add0127c452f2d5cb8047f30fedeb4dbab840ea5b9012b84ef0652d340d9e57df94a36f9e0ca5796b370742dc050531b
-EBUILD php-8.3.3.ebuild 24009 BLAKE2B 777d6bf3fb938135e9e5bde90e49813eca2cd95896785a02b42a84179505150c87211877582e4012a6f29fb67fc0bdad1a3607f1c0a4bc7bf70ae68cea36a5d1 SHA512 b5218ec48794ead1467a114df8e5a5251453834a974fceb99e6c7a947239fb32c8ca2a34e28dc3d84b05d55364503fb640838924d26fce6e417b65d1eefff41a
+EBUILD php-8.3.3-r1.ebuild 23724 BLAKE2B 6938c0c76366ac47b51f067f99a0c6950c4885b18f557053dd97b43225d3b0f1deede42a0aaa7cae03815297427463822ccbf7e4f4f4dbca7c84d88905c4a838 SHA512 5dde714a61199cddbf6830f2d9edd536918afd33e59119f098c49e69fd814e6a0e4f5f6e1482680ab7c8cd98d1f39dabdb82838d441df39cd0ef80b503dd9041
MISC metadata.xml 4134 BLAKE2B 62c1c5052c50db537586edc1db639fa94e24609ea027208177566ae7f7f9199103bb3ef5b636766508027e8e7aacb8451d25b57e981b582bc42299e199696a68 SHA512 b059c7552c18dfcabe82170c1ae5978421284f3ea9ea9505359c1441ccc76b668a5555919251c6ca55f1f450da9363a8ac7b30c393a8506921f790e0f4197dbb
diff --git a/dev-lang/php/php-8.3.3.ebuild b/dev-lang/php/php-8.3.3-r1.ebuild
index 488c1dbec923..8fe4000652a6 100644
--- a/dev-lang/php/php-8.3.3.ebuild
+++ b/dev-lang/php/php-8.3.3-r1.ebuild
@@ -174,10 +174,6 @@ php_install_ini() {
local phpinisrc="php.ini-production-${phpsapi}"
cp php.ini-production "${phpinisrc}" || die
- # Set the extension dir
- sed -e "s|^extension_dir .*$|extension_dir = ${extension_dir}|g" \
- -i "${phpinisrc}" || die
-
# Set the include path to point to where we want to find PEAR
# packages
local sed_src='^;include_path = ".:/php.*'
@@ -198,7 +194,7 @@ php_install_ini() {
if use opcache; then
elog "Adding opcache to $PHP_EXT_INI_DIR"
- echo "zend_extension=${PHP_DESTDIR}/$(get_libdir)/opcache.so" >> \
+ echo "zend_extension = opcache.so" >> \
"${D}/${PHP_EXT_INI_DIR}"/opcache.ini
dosym "../ext/opcache.ini" \
"${PHP_EXT_INI_DIR_ACTIVE#${EPREFIX}}/opcache.ini"
@@ -508,6 +504,10 @@ src_configure() {
# in main/build-defs.h which is included in main/php.h which is
# included by basically everything; so, avoiding a rebuild after
# changing it is not an easy job.
+ #
+ # The upstream build system also does not support building the
+ # apache2 and embed SAPIs at the same time, presumably because they
+ # both produce a libphp.so.
local one_sapi
local sapi
mkdir "${WORKDIR}/sapis-build" || die
@@ -599,20 +599,15 @@ src_install() {
fi
done
- # Makefile forgets to create this before trying to write to it...
- dodir "${PHP_DESTDIR#${EPREFIX}}/bin"
-
- # Install php environment (without any sapis)
+ # Install SAPI-independent targets
cd "${WORKDIR}/sapis-build/$first_sapi" || die
emake INSTALL_ROOT="${D}" \
install-build install-headers install-programs
-
- local extension_dir="$("${ED}/${PHP_DESTDIR#${EPREFIX}}/bin/php-config" --extension-dir)"
+ use opcache && emake INSTALL_ROOT="${D}" install-modules
# Create the directory where we'll put version-specific php scripts
keepdir "/usr/share/php${PHP_MV}"
- local file=""
local sapi_list=""
for sapi in ${SAPIS}; do
@@ -678,12 +673,6 @@ src_install() {
fi
done
- # Installing opcache module
- if use opcache ; then
- into "${PHP_DESTDIR#${EPREFIX}}"
- dolib.so "modules/opcache$(get_libname)"
- fi
-
# Install env.d files
newenvd "${FILESDIR}/20php5-envd" "20php${SLOT}"
sed -e "s|/lib/|/$(get_libdir)/|g" -i "${ED}/etc/env.d/20php${SLOT}" || die