summaryrefslogtreecommitdiff
path: root/dev-lang/php/php-8.2.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php/php-8.2.17.ebuild')
-rw-r--r--dev-lang/php/php-8.2.17.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-lang/php/php-8.2.17.ebuild b/dev-lang/php/php-8.2.17.ebuild
index f27df005dc4f..abe657f95e1d 100644
--- a/dev-lang/php/php-8.2.17.ebuild
+++ b/dev-lang/php/php-8.2.17.ebuild
@@ -151,6 +151,7 @@ PATCHES=(
"${FILESDIR}/php-capstone-optional.patch"
"${FILESDIR}/php-8.2.8-openssl-tests.patch"
"${FILESDIR}/php-8.1.27-implicit-decls.patch"
+ "${FILESDIR}/fix-musl-llvm.patch"
)
# ARM/Windows functions (bug 923335)
@@ -322,6 +323,12 @@ src_prepare() {
# https://github.com/php/php-src/issues/12801
rm ext/pcre/tests/gh11374.phpt || die
+
+ # This is a memory usage test with hard-coded limits. Whenever the
+ # limits are surpassed... they get increased... but in the meantime,
+ # the tests fail. This is not really a test that end users should
+ # be running pre-install, in my opinion. Bug 927461.
+ rm ext/fileinfo/tests/bug78987.phpt || die
}
src_configure() {