summaryrefslogtreecommitdiff
path: root/dev-lang/perl/perl-5.38.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/perl/perl-5.38.2-r2.ebuild')
-rw-r--r--dev-lang/perl/perl-5.38.2-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-lang/perl/perl-5.38.2-r2.ebuild b/dev-lang/perl/perl-5.38.2-r2.ebuild
index a6120f17e34e..e49b6cd534d7 100644
--- a/dev-lang/perl/perl-5.38.2-r2.ebuild
+++ b/dev-lang/perl/perl-5.38.2-r2.ebuild
@@ -577,7 +577,7 @@ src_configure() {
myconf "-${myndbm}i_ndbm" "-${mygdbm}i_gdbm" "-${mydb}i_db"
if use alpha && [[ "$(tc-getCC)" = "ccc" ]] ; then
- ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
+ ewarn "Perl will not be built with berkdb support, use gcc if you need it..."
myconf -Ui_db -Ui_ndbm
fi
@@ -650,7 +650,7 @@ src_configure() {
if use prefix ; then
# Set a hook to check for each detected library whether it actually works.
export libscheck="
- ( echo 'main(){}' > '${T}'/conftest.c &&
+ ( echo 'int main(){}' > '${T}'/conftest.c &&
$(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
) || xxx=/dev/null"