summaryrefslogtreecommitdiff
path: root/dev-lang/pcc/pcc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/pcc/pcc-9999.ebuild')
-rw-r--r--dev-lang/pcc/pcc-9999.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-lang/pcc/pcc-9999.ebuild b/dev-lang/pcc/pcc-9999.ebuild
deleted file mode 100644
index a507114c0400..000000000000
--- a/dev-lang/pcc/pcc-9999.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools
-
-DESCRIPTION="pcc portable c compiler"
-HOMEPAGE="http://pcc.ludd.ltu.se"
-
-if [[ ${PV} == 9999 ]]; then
- ECVS_SERVER="pcc.ludd.ltu.se:/cvsroot"
- ECVS_MODULE="${PN}"
- inherit cvs
-
- S="${WORKDIR}/${PN}"
-else
- SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-
-DEPEND=">=dev-libs/pcc-libs-${PV}"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- sed -i -e 's/AC_CHECK_PROG(strip,strip,yes,no)//' configure.ac || die "Failed to fix configure.ac"
- sed -i -e 's/AC_SUBST(strip)//' configure.ac || die "Failed to fix configure.ac more"
- eautoreconf
-}
-
-src_configure() {
- econf --disable-stripping
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-}