summaryrefslogtreecommitdiff
path: root/dev-lang/nim/nim-1.6.14-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/nim/nim-1.6.14-r1.ebuild')
-rw-r--r--dev-lang/nim/nim-1.6.14-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/nim/nim-1.6.14-r1.ebuild b/dev-lang/nim/nim-1.6.14-r1.ebuild
index 58e6390b88ed..07e043cf4ffb 100644
--- a/dev-lang/nim/nim-1.6.14-r1.ebuild
+++ b/dev-lang/nim/nim-1.6.14-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -104,12 +104,14 @@ src_compile() {
edo ./build.sh --parallel "$(makeopts_jobs)"
- ebegin "Waiting for unfinished jobs"
- while [[ ! -f "bin/nim" ]]; do
- sleep 1
+ ebegin "Waiting for unfinished parallel jobs"
+ while [[ ! -f "bin/nim" ]] ; do
+ sleep 3
done
+ sleep 10
eend 0
+ edo chmod +x ./bin/nim
edo ./bin/nim compile koch
edo ./koch boot -d:nimUseLinenoise --skipParentCfg:off
edo ./koch tools