summaryrefslogtreecommitdiff
path: root/dev-lang/nasm/nasm-2.13.03-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/nasm/nasm-2.13.03-r1.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.13.03-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-lang/nasm/nasm-2.13.03-r1.ebuild b/dev-lang/nasm/nasm-2.13.03-r1.ebuild
deleted file mode 100644
index 6c15c6756966..000000000000
--- a/dev-lang/nasm/nasm-2.13.03-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic
-
-DESCRIPTION="groovy little assembler"
-HOMEPAGE="https://www.nasm.us/"
-SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-# [fonts note] doc/psfonts.ph defines ordered list of font preference.
-# Currently 'media-fonts/source-pro' is most preferred and is able to
-# satisfy all 6 font flavours: tilt, chapter, head, etc.
-DEPEND="
- dev-lang/perl
- doc? (
- app-text/ghostscript-gpl
- dev-perl/Font-TTF
- dev-perl/Sort-Versions
- media-fonts/source-pro
- virtual/perl-File-Spec
- )
-"
-
-S=${WORKDIR}/${P/_}
-PATCHES=(
- "${FILESDIR}"/${PN}-2.13.01-fix-docdir.patch
- "${FILESDIR}"/${PN}-2.13.01-gcc-8.patch
- "${FILESDIR}"/${PN}-2.13.03-bsd-cp-doc.patch
-)
-
-src_configure() {
- strip-flags
- default
-}
-
-src_compile() {
- default
- use doc && emake doc
-}
-
-src_install() {
- default
- emake DESTDIR="${D}" install_rdf $(usex doc install_doc '')
-}