summaryrefslogtreecommitdiff
path: root/dev-lang/mono
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/mono-6.12.0.199-r1.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index d279b44eb2e1..73323e32c6cc 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -5,5 +5,6 @@ DIST mono-6.12.0.182.tar.xz 303230932 BLAKE2B fc959e1d57d91670e8adf8ab64d3c0f16b
DIST mono-6.12.0.199.tar.xz 304146664 BLAKE2B a38f0f1b80b300132247cee4621fc59bd65845c919ccd0cc55e00928b8a1b85b0695a9bb436c3efc0afd4e7dfa001714485964cf44239bb7c438ca6ed818dabf SHA512 9e379aaeb2e8750edbda74648c0ae9cc8cb9b2d7af85512bf2e729132c2e0322e776ef0b7657da708cbc1ae2a62f5532519d339fa68f465b30a65ca30d4a1e51
EBUILD mono-6.12.0.122.ebuild 3526 BLAKE2B 2333187c97e31a5e09056f123abd5ca984ae5888e842a980a68df5fc0ea2cd2d6ead3b3dcfe29067a3ea25481e0c1c728af8f0485c4ad2e6b0e68248639f346c SHA512 dd998ddb53d65672670c0feb9bab1a96431f5bf7c1791ada827bad6cb0e69c9fa4ea378eea92bf9a87c646716768dbac722bfc1b026be569657c69d949b6f69e
EBUILD mono-6.12.0.182.ebuild 3518 BLAKE2B eaee6daf89ed51614ce54e1756ba34b0a134e1fd1c3ee3cb7a4243f0cdd778fe836e91d5d03c53b2ac6b9f7bc49c17a5905e8d4ca01f845af941a556353e2b4b SHA512 c5a63ad68c5fa90e12aa0af1a07624f975ad73e928c6249331d9f2d64f9c1921093fb7d774e006d5a1e75ffe6d3591de0331c962b02e0f99c25b8495a7fa5602
+EBUILD mono-6.12.0.199-r1.ebuild 3597 BLAKE2B fd5aea9135969ff2e168563d4d4fcdad564071909f471b89b32d24526e515f20ae8259d2e88eef4797751eb9cb35e1c6b8586747ea0ccf0a7b5d5445b1438531 SHA512 4b21200d90321ebb4d8678d84f70a731d9a4f428114ceec8b9fd364587524b1dd833ba181391cf3870dd41c5f5174faafcd222ba3fce45ae5a2b3665f18a9472
EBUILD mono-6.12.0.199.ebuild 3520 BLAKE2B bb714e5df2f8d45736e06247e0954f85d1da2e1a620212085421ce55f752144696e619917b5fe87a724e2cd08fb96e7b5cc4438acd379a47a95817b073e48c9a SHA512 ae93c91462f48ed49fc73c7af2580c9c6d8a0588520458d213c3ff2ac69cb7495b5f04fbc15666909a5bc60e92d6aa206cd9d6b88e98e521b6754ab96dfc36b4
MISC metadata.xml 582 BLAKE2B 498a6035f8da9da20ae51144d40ff5c599576bc3aa76471d655fb1eb127bc9fac7d5e3c6ef20d2c3d7befce109931f6a2ce6751183d1444eda6a39456068ceb7 SHA512 691d1cba0271329b683c9c81651343dafaeab891aab0b9396c7f620ff1897848d2c7171d3ad73e7feb6ac2f63e98262c9ee3ee6f679e4a08bf7d1b6973921b2d
diff --git a/dev-lang/mono/mono-6.12.0.199-r1.ebuild b/dev-lang/mono/mono-6.12.0.199-r1.ebuild
new file mode 100644
index 000000000000..204593665083
--- /dev/null
+++ b/dev-lang/mono/mono-6.12.0.199-r1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CHECKREQS_DISK_BUILD="4500M"
+inherit autotools check-reqs flag-o-matic linux-info mono-env pax-utils multilib-minimal
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="https://mono-project.com"
+SRC_URI="https://download.mono-project.com/sources/mono/${P}.tar.xz"
+
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -riscv ~x86 ~amd64-linux"
+IUSE="doc minimal nls pax-kernel selinux xen"
+
+# Note: mono works incorrect with older versions of libgdiplus
+# Details on dotnet overlay issue: https://github.com/gentoo/dotnet/issues/429
+DEPEND="
+ app-crypt/mit-krb5[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ ia64? ( sys-libs/libunwind )
+ !minimal? ( >=dev-dotnet/libgdiplus-6.0.2 )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ ${DEPEND}
+ app-misc/ca-certificates
+ selinux? ( sec-policy/selinux-mono )
+"
+# CMake is used for bundled deps
+BDEPEND="
+ dev-util/cmake
+ sys-devel/bc
+ app-alternatives/yacc
+ pax-kernel? ( sys-apps/elfix )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.12-try-catch.patch
+ "${FILESDIR}"/${PN}-6.12.0.122-disable-automagic-ccache.patch
+)
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if use kernel_linux ; then
+ if linux_config_exists ; then
+ linux_chkconfig_builtin SYSVIPC || die "SYSVIPC not enabled in the kernel"
+ else
+ # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
+ ewarn "kernel config not found"
+ ewarn "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See https://bugs.gentoo.org/261869 for more info."
+ fi
+ fi
+
+ # bug #687892
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ mono-env_pkg_setup
+ check-reqs_pkg_setup
+}
+
+src_prepare() {
+ # We need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTECT is enabled, bug #286280
+ # RANDMMAP kills the build process too, bug #347365
+ # We use paxmark.sh to get PT/XT logic, bug #532244
+ if use pax-kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ default
+
+ # PATCHES contains configure.ac patch
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ # Many, many unsafe warnings. Miscompiled with -O3 too: bug #915985.
+ append-flags -O2 -fno-strict-aliasing
+ filter-lto
+
+ local myeconfargs=(
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --disable-dtrace
+ --enable-system-aot
+ $(multilib_native_use_with doc mcs-docs)
+ $(use_enable nls)
+ )
+
+ # Workaround(?) for bug #779025
+ # May be able to do a real fix by adjusting path used?
+ if multilib_is_native_abi ; then
+ myeconfargs+=( --enable-system-aot )
+ else
+ myeconfargs+=( --disable-system-aot )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ emake -C mcs/tests check
+}
+
+multilib_src_install() {
+ default
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}
+
+pkg_postinst() {
+ # bug #762265
+ cert-sync "${EROOT}"/etc/ssl/certs/ca-certificates.crt
+}