summaryrefslogtreecommitdiff
path: root/dev-lang/mono/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mono/files')
-rw-r--r--dev-lang/mono/files/mono-4.4.1.0-x86_32.patch20
-rw-r--r--dev-lang/mono/files/mono-4.8.0.371-makedev.patch34
-rw-r--r--dev-lang/mono/files/mono-4.8.0.371-x86_32.patch27
-rw-r--r--dev-lang/mono/files/mono-5.0.1.1-x86_32.patch21
-rw-r--r--dev-lang/mono/files/mono-5.12-try-catch.patch31
5 files changed, 0 insertions, 133 deletions
diff --git a/dev-lang/mono/files/mono-4.4.1.0-x86_32.patch b/dev-lang/mono/files/mono-4.4.1.0-x86_32.patch
deleted file mode 100644
index 751c057e6ce4..000000000000
--- a/dev-lang/mono/files/mono-4.4.1.0-x86_32.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Native toolchain can default to different ABI (amd64 in bug case).
-Set target to i386.
-https://bugs.gentoo.org/600664
-diff -Naur a/mono/mini/aot-compiler.c b/mono/mini/aot-compiler.c
---- a/mono/mini/aot-compiler.c 2016-06-22 04:31:58.000000000 -0500
-+++ b/mono/mini/aot-compiler.c 2017-12-08 14:25:35.338251941 -0600
-@@ -9438,7 +9438,12 @@
- const char *tool_prefix = acfg->aot_opts.tool_prefix ? acfg->aot_opts.tool_prefix : "";
- char *ld_flags = acfg->aot_opts.ld_flags ? acfg->aot_opts.ld_flags : g_strdup("");
-
--#if defined(TARGET_AMD64) && !defined(TARGET_MACH)
-+#if defined(TARGET_X86)
-+#define LD_OPTIONS "-m elf_i386"
-+#if !defined(TARGET_MACH)
-+#define AS_OPTIONS "--32"
-+#endif
-+#elif defined(TARGET_AMD64) && !defined(TARGET_MACH)
- #define AS_OPTIONS "--64"
- #elif defined(TARGET_POWERPC64)
- #define AS_OPTIONS "-a64 -mppc64"
diff --git a/dev-lang/mono/files/mono-4.8.0.371-makedev.patch b/dev-lang/mono/files/mono-4.8.0.371-makedev.patch
deleted file mode 100644
index 7a4a44b3e72d..000000000000
--- a/dev-lang/mono/files/mono-4.8.0.371-makedev.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://bugs.gentoo.org/575232
-diff --git a/configure.ac b/configure.ac
-index fa5977b..2832c69 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -416,6 +416,10 @@ AC_HEADER_STDC
- AC_LIBTOOL_WIN32_DLL
- # This causes monodis to not link correctly
- #AC_DISABLE_FAST_INSTALL
-+
-+#lookup makedev() header
-+AC_HEADER_MAJOR
-+
- AM_PROG_LIBTOOL
- # Use dolt (http://dolt.freedesktop.org/) instead of libtool for building.
- DOLT
-diff --git a/mono/io-layer/processes.c b/mono/io-layer/processes.c
-index 53c271a..7ff8d03 100644
---- a/mono/io-layer/processes.c
-+++ b/mono/io-layer/processes.c
-@@ -45,6 +45,13 @@
- #include <utime.h>
- #endif
-
-+/* makedev() macro */
-+#ifdef MAJOR_IN_MKDEV
-+#include <sys/mkdev.h>
-+#elif defined MAJOR_IN_SYSMACROS
-+#include <sys/sysmacros.h>
-+#endif
-+
- /* sys/resource.h (for rusage) is required when using osx 10.3 (but not 10.4) */
- #ifdef __APPLE__
- #include <TargetConditionals.h>
diff --git a/dev-lang/mono/files/mono-4.8.0.371-x86_32.patch b/dev-lang/mono/files/mono-4.8.0.371-x86_32.patch
deleted file mode 100644
index 063ea634fa4c..000000000000
--- a/dev-lang/mono/files/mono-4.8.0.371-x86_32.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Native toolchain can default to different ABI (amd64 in bug case).
-Set target to i386.
-https://bugs.gentoo.org/600664
-diff --git a/mono/mini/aot-compiler.c b/mono/mini/aot-compiler.c
-index a1c359f..beaaf76 100644
---- a/mono/mini/aot-compiler.c
-+++ b/mono/mini/aot-compiler.c
-@@ -9842,7 +9842,9 @@ compile_asm (MonoAotCompile *acfg)
- const char *tool_prefix = acfg->aot_opts.tool_prefix ? acfg->aot_opts.tool_prefix : "";
- char *ld_flags = acfg->aot_opts.ld_flags ? acfg->aot_opts.ld_flags : g_strdup("");
-
--#if defined(TARGET_AMD64) && !defined(TARGET_MACH)
-+#if defined(TARGET_X86) && !defined(TARGET_MACH)
-+#define AS_OPTIONS "--32"
-+#elif defined(TARGET_AMD64) && !defined(TARGET_MACH)
- #define AS_OPTIONS "--64"
- #elif defined(TARGET_POWERPC64)
- #define AS_OPTIONS "-a64 -mppc64"
-@@ -9886,6 +9888,8 @@ compile_asm (MonoAotCompile *acfg)
- #define LD_OPTIONS "--shared"
- #elif defined(TARGET_POWERPC64)
- #define LD_OPTIONS "-m elf64ppc"
-+#elif defined(TARGET_X86)
-+#define LD_OPTIONS "-m elf_i386"
- #endif
-
- #ifndef LD_OPTIONS
diff --git a/dev-lang/mono/files/mono-5.0.1.1-x86_32.patch b/dev-lang/mono/files/mono-5.0.1.1-x86_32.patch
deleted file mode 100644
index 08d443a22038..000000000000
--- a/dev-lang/mono/files/mono-5.0.1.1-x86_32.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Native toolchain can default to different ABI (amd64 in bug case).
-Set target to i386.
-https://bugs.gentoo.org/600664
-diff --git a/mono/mini/aot-compiler.c b/mono/mini/aot-compiler.c
-index 0656a57..690c96b 100644
---- a/mono/mini/aot-compiler.c
-+++ b/mono/mini/aot-compiler.c
-@@ -9926,4 +9926,6 @@ compile_asm (MonoAotCompile *acfg)
- #ifdef TARGET_WIN32_MSVC
- #define AS_OPTIONS "-c -x assembler"
-+#elif defined(TARGET_X86) && !defined(TARGET_MACH)
-+#define AS_OPTIONS "--32"
- #elif defined(TARGET_AMD64) && !defined(TARGET_MACH)
- #define AS_OPTIONS "--64"
-@@ -9981,4 +9983,6 @@ compile_asm (MonoAotCompile *acfg)
- #elif defined(TARGET_POWERPC64)
- #define LD_OPTIONS "-m elf64ppc"
-+#elif defined(TARGET_X86)
-+#define LD_OPTIONS "-m elf_i386"
- #endif
-
diff --git a/dev-lang/mono/files/mono-5.12-try-catch.patch b/dev-lang/mono/files/mono-5.12-try-catch.patch
deleted file mode 100644
index 051c72be6859..000000000000
--- a/dev-lang/mono/files/mono-5.12-try-catch.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -ur mono-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs mono-patched-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs
---- mono-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2017-11-17 18:12:57.000000000 +0300
-+++ mono-patched-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2017-12-06 06:24:45.067519852 +0300
-@@ -2810,14 +2810,21 @@
-
- internal override object ClipboardRetrieve(IntPtr handle, int type, XplatUI.ClipboardToObject converter)
- {
-- XConvertSelection(DisplayHandle, handle, (IntPtr)type, (IntPtr)type, FosterParent, IntPtr.Zero);
-+ try
-+ {
-+ XConvertSelection(DisplayHandle, handle, (IntPtr)type, (IntPtr)type, FosterParent, IntPtr.Zero);
-
-- Clipboard.Retrieving = true;
-- while (Clipboard.Retrieving) {
-- UpdateMessageQueue(null, false);
-- }
-+ Clipboard.Retrieving = true;
-+ while (Clipboard.Retrieving) {
-+ UpdateMessageQueue(null, false);
-+ }
-
-- return Clipboard.Item;
-+ return Clipboard.Item;
-+ }
-+ catch (Exception ex)
-+ {
-+ return null;
-+ }
- }
-
- internal override void ClipboardStore (IntPtr handle, object obj, int type, XplatUI.ObjectToClipboard converter, bool copy)