summaryrefslogtreecommitdiff
path: root/dev-lang/mercury/mercury-13.05.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mercury/mercury-13.05.2.ebuild')
-rw-r--r--dev-lang/mercury/mercury-13.05.2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/mercury/mercury-13.05.2.ebuild b/dev-lang/mercury/mercury-13.05.2.ebuild
index b0836202a1bf..99339c2a2bc4 100644
--- a/dev-lang/mercury/mercury-13.05.2.ebuild
+++ b/dev-lang/mercury/mercury-13.05.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=2
@@ -69,7 +69,7 @@ src_configure() {
src_compile() {
# Build Mercury using base llds grade
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_LDFLAGS='${LDFLAGS}' \
EXTRA_LD_LIBFLAGS='${LDFLAGS}'" \
@@ -88,7 +88,7 @@ src_compile() {
# Rebuild Mercury compiler using the just built mercury_compiler
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_LDFLAGS='${LDFLAGS}' \
EXTRA_LD_LIBFLAGS='${LDFLAGS}'" \
@@ -99,7 +99,7 @@ src_compile() {
# compile the llds base grade. Since src_test() is run before
# src_install() we compile the default grade now
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_LDFLAGS='${LDFLAGS}' \
EXTRA_LD_LIBFLAGS='${LDFLAGS}'" \
@@ -141,7 +141,7 @@ src_test() {
src_install() {
emake \
- PARALLEL=${MAKEOPTS} \
+ PARALLEL="'${MAKEOPTS}'" \
MMAKEFLAGS="EXTRA_MLFLAGS=--no-strip \
EXTRA_LDFLAGS='${LDFLAGS}' \
EXTRA_LD_LIBFLAGS='${LDFLAGS}'" \