summaryrefslogtreecommitdiff
path: root/dev-lang/kotlin-bin
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/kotlin-bin')
-rw-r--r--dev-lang/kotlin-bin/Manifest2
-rw-r--r--dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild59
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-lang/kotlin-bin/Manifest b/dev-lang/kotlin-bin/Manifest
index 7b65e63f47d6..4ceeee1e5012 100644
--- a/dev-lang/kotlin-bin/Manifest
+++ b/dev-lang/kotlin-bin/Manifest
@@ -1,5 +1,3 @@
-DIST kotlin-compiler-1.9.22.zip 91026092 BLAKE2B 2fc776b27e30a9d75640dc8fc004bfec5207b1b79c2742aa6a8a75971a8b41310cc16712d6d0921e1fa7545031a75ca8256c48f5c1e13f4e36d82df2574d5699 SHA512 d0e1bdfb1918f007444b1cef6e0c29c2c1846819edd60d016ed62327ea6d2cb505aa18658f916f88b91d9fbdfe0b155ad3361728d6a7a9062806d982bc9b8c6c
DIST kotlin-compiler-1.9.23.zip 91045770 BLAKE2B f15bf111b0de8527312ae3ffced8fd80812a8ea949f4157d21085966ec7f9c19facf116cc70915d41aca2fb4b3c3d1d9d3cebe23c5312728f295204528c82f2d SHA512 6baea5f968b8cd21a89fd80302a26761b775d2631d5a434775eecf1c4bbc1e07b657f389da4c4d2cd10e3687908e0417d12b94ed822b029a7126ae1988dba445
-EBUILD kotlin-bin-1.9.22.ebuild 1005 BLAKE2B 0c2efbc96602feaa82e87463c19ab244d44bd7b9596177346ae08331d37a53e1f033f41cc0ee557e7b806997a1d553b8e33eb8abd69bd8552db316053276d21f SHA512 c96c829a4c8f21ed7a82de4af30756806d27f72394242115a1cc34fa755f93f1d1cd7a42abfc6bb40ab3c4209ea6428464ccc9a32aadb16e077f132194abb085
EBUILD kotlin-bin-1.9.23.ebuild 1005 BLAKE2B 0c2efbc96602feaa82e87463c19ab244d44bd7b9596177346ae08331d37a53e1f033f41cc0ee557e7b806997a1d553b8e33eb8abd69bd8552db316053276d21f SHA512 c96c829a4c8f21ed7a82de4af30756806d27f72394242115a1cc34fa755f93f1d1cd7a42abfc6bb40ab3c4209ea6428464ccc9a32aadb16e077f132194abb085
MISC metadata.xml 696 BLAKE2B 5ff5c3681ab7e083f1a2ea607b183c279c50a022eea2237bfc705d67b8e3ddac7d61fdb1774ac2d6214e03d61d0fb03367cd399734a4b537dcf53a3d8cb14de1 SHA512 44186263fa0709e3d4fadd54cc80e1063d215f908855be9476062259387ec9d968f35bfe8da6fbc716be22a53212630676157fd08fbebd67c20dc4a4485b5a44
diff --git a/dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild b/dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild
deleted file mode 100644
index 7e3629cfadfc..000000000000
--- a/dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit java-pkg-2 wrapper
-
-DESCRIPTION="Statically typed language that targets the JVM and JavaScript"
-HOMEPAGE="https://kotlinlang.org/
- https://github.com/JetBrains/kotlin/"
-SRC_URI="https://github.com/JetBrains/kotlin/releases/download/v${PV}/kotlin-compiler-${PV}.zip"
-S="${WORKDIR}/kotlinc"
-
-LICENSE="Apache-2.0 BSD MIT NPL-1.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-DEPEND="
- >=virtual/jdk-1.8:*
-"
-BDEPEND="
- app-arch/unzip
-"
-
-src_prepare() {
- default
-
- rm bin/*.bat || die
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- java-pkg_dojar lib/*
-
- # Follow the Java eclass JAR installation path.
- local app_home="/usr/share/${PN}"
-
- exeinto "${app_home}/bin"
- doexe bin/*
-
- local -a exes=(
- kapt
- kotlin
- kotlinc
- kotlinc-js
- kotlinc-jvm
- kotlin-dce-js
- )
- local exe
- for exe in "${exes[@]}" ; do
- make_wrapper "${exe}" "${app_home}/bin/${exe}"
- done
-}