summaryrefslogtreecommitdiff
path: root/dev-lang/julia/julia-1.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/julia/julia-1.7.3.ebuild')
-rw-r--r--dev-lang/julia/julia-1.7.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/julia/julia-1.7.3.ebuild b/dev-lang/julia/julia-1.7.3.ebuild
index 39455ca05597..1b2d16111014 100644
--- a/dev-lang/julia/julia-1.7.3.ebuild
+++ b/dev-lang/julia/julia-1.7.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit llvm pax-utils toolchain-funcs
+inherit flag-o-matic llvm pax-utils toolchain-funcs
# correct versions for stdlibs are in deps/checksums
# for everything else, run with network-sandbox and wait for the crash
@@ -123,6 +123,9 @@ src_prepare() {
}
src_configure() {
+ # bug #855602
+ filter-lto
+
use system-llvm && ewarn "You have enabled system-llvm. This is unsupported by upstream and may not work."
# julia does not play well with the system versions of libuv