summaryrefslogtreecommitdiff
path: root/dev-lang/julia/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/julia/files')
-rw-r--r--dev-lang/julia/files/julia-0.6.3-fix_build_system.patch (renamed from dev-lang/julia/files/julia-0.6.0-fix_build_system.patch)19
-rw-r--r--dev-lang/julia/files/julia-9999-fix_build_system.patch29
2 files changed, 34 insertions, 14 deletions
diff --git a/dev-lang/julia/files/julia-0.6.0-fix_build_system.patch b/dev-lang/julia/files/julia-0.6.3-fix_build_system.patch
index 6f8041617751..41e64672adf8 100644
--- a/dev-lang/julia/files/julia-0.6.0-fix_build_system.patch
+++ b/dev-lang/julia/files/julia-0.6.3-fix_build_system.patch
@@ -1,8 +1,17 @@
diff --git a/Make.inc b/Make.inc
-index e30c150..e6fdbb2 100644
+index 7f3a37c..3560d93 100644
--- a/Make.inc
+++ b/Make.inc
-@@ -399,7 +399,7 @@ ifneq ($(OS), WINNT)
+@@ -180,7 +180,7 @@ USE_GPL_LIBS ?= 1
+ # Directories where said libraries get installed to
+ prefix ?= $(BUILDROOT)/julia-$(JULIA_COMMIT)
+ bindir := $(prefix)/bin
+-libdir := $(prefix)/lib
++libdir := $(prefix)/GENTOOLIBDIR
+ libexecdir := $(prefix)/libexec
+ datarootdir := $(prefix)/share
+ docdir := $(datarootdir)/doc/julia
+@@ -400,7 +400,7 @@ ifneq ($(OS), WINNT)
JCXXFLAGS += -pedantic
endif
DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
@@ -11,7 +20,7 @@ index e30c150..e6fdbb2 100644
endif
ifeq ($(USECLANG),1)
-@@ -410,7 +410,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+@@ -411,7 +411,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
JCPPFLAGS := -fasynchronous-unwind-tables
JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
@@ -20,7 +29,7 @@ index e30c150..e6fdbb2 100644
ifeq ($(OS), Darwin)
ifeq ($(USE_LIBCPP), 1)
MACOSX_VERSION_MIN := 10.8
-@@ -439,7 +439,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+@@ -440,7 +440,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
JCPPFLAGS :=
JCXXFLAGS := -pipe $(fPIC) -fno-rtti
DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
@@ -60,7 +69,7 @@ index 743804d..e06dde0 100644
cleanall: clean
diff --git a/src/Makefile b/src/Makefile
-index f71f53d..7cdd23f 100644
+index 9fde74d..e01ab2e 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -85,20 +85,8 @@ PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLI
diff --git a/dev-lang/julia/files/julia-9999-fix_build_system.patch b/dev-lang/julia/files/julia-9999-fix_build_system.patch
index d7866f46b3e0..336d6e3e590c 100644
--- a/dev-lang/julia/files/julia-9999-fix_build_system.patch
+++ b/dev-lang/julia/files/julia-9999-fix_build_system.patch
@@ -1,8 +1,17 @@
diff --git a/Make.inc b/Make.inc
-index e77681669..bc17c6fd0 100644
+index 8cb2c1014..d3be9de8e 100644
--- a/Make.inc
+++ b/Make.inc
-@@ -399,7 +399,7 @@ ifneq ($(OS), WINNT)
+@@ -178,7 +178,7 @@ USE_GPL_LIBS ?= 1
+ # Directories where said libraries get installed to
+ prefix ?= $(BUILDROOT)/julia-$(JULIA_COMMIT)
+ bindir := $(prefix)/bin
+-libdir := $(prefix)/lib
++libdir := $(prefix)/GENTOOLIBDIR
+ libexecdir := $(prefix)/libexec
+ datarootdir := $(prefix)/share
+ docdir := $(datarootdir)/doc/julia
+@@ -410,7 +410,7 @@ ifneq ($(OS), WINNT)
JCXXFLAGS += -pedantic
endif
DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
@@ -11,7 +20,7 @@ index e77681669..bc17c6fd0 100644
endif
ifeq ($(USECLANG),1)
-@@ -410,7 +410,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+@@ -421,7 +421,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
JCPPFLAGS := -fasynchronous-unwind-tables
JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
@@ -20,7 +29,7 @@ index e77681669..bc17c6fd0 100644
ifeq ($(OS), Darwin)
ifeq ($(USE_LIBCPP), 1)
MACOSX_VERSION_MIN := 10.8
-@@ -439,7 +439,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+@@ -450,7 +450,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
JCPPFLAGS :=
JCXXFLAGS := -pipe $(fPIC) -fno-rtti
DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
@@ -30,10 +39,10 @@ index e77681669..bc17c6fd0 100644
ifeq ($(USECCACHE), 1)
diff --git a/doc/Makefile b/doc/Makefile
-index 743804d8b..e06dde030 100644
+index 89b79880d..c3125fde1 100644
--- a/doc/Makefile
+++ b/doc/Makefile
-@@ -25,7 +25,7 @@ deps: UnicodeData.txt
+@@ -29,7 +29,7 @@ deps: UnicodeData.txt
$(JLCHECKSUM) UnicodeData.txt
clean:
@@ -43,13 +52,14 @@ index 743804d8b..e06dde030 100644
cleanall: clean
diff --git a/src/Makefile b/src/Makefile
-index d3ff98900..9c4d889b4 100644
+index 257152d24..240a4a350 100644
--- a/src/Makefile
+++ b/src/Makefile
-@@ -87,14 +87,7 @@ PUBLIC_HEADERS += $(LIBUV_INC)/uv*
+@@ -85,16 +85,7 @@ UV_HEADERS += uv/*.h
endif
- PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLIC_HEADERS)))
+ PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLIC_HEADERS)) $(UV_HEADERS))
+-ifeq ($(JULIACODEGEN),LLVM)
-# In LLVM < 3.4, --ldflags includes both options and libraries, so use it both before and after --libs
-# In LLVM >= 3.4, --ldflags has only options, and --system-libs has the libraries.
-ifneq ($(USE_LLVM_SHLIB),1)
@@ -58,6 +68,7 @@ index d3ff98900..9c4d889b4 100644
-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM
-FLAGS += -DLLVM_SHLIB
-endif # USE_LLVM_SHLIB == 1
+-endif
+LLVMLINK = $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --libs) $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --system-libs)
COMMON_LIBS := -L$(build_shlibdir) -L$(build_libdir) $(LIBUV) $(LIBUTF8PROC) $(NO_WHOLE_ARCHIVE) $(LLVMLINK) $(OSLIBS)