summaryrefslogtreecommitdiff
path: root/dev-lang/ispc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/Manifest2
-rw-r--r--dev-lang/ispc/ispc-1.22.0-r1.ebuild99
2 files changed, 0 insertions, 101 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
index fd42123fc576..8fb3068c9f3e 100644
--- a/dev-lang/ispc/Manifest
+++ b/dev-lang/ispc/Manifest
@@ -1,5 +1,3 @@
-DIST ispc-1.22.0.gh.tar.gz 19618494 BLAKE2B 0dae95d792e4d629b38a9775c2c600131374c69dfa086d6a67100e40e5005ef054b9a651f418e0452a19ee4e64ffd830bfaa787b14e706473e8fab1d2380f0fd SHA512 4436ea37003b4cbfefcbf4c18212d0e98536243ae8f01053817d579e04205a4dcd4ab7b2b282fec99fc617009fdbea340b348cf4a2134240d2fcfc6bcaf6b60c
DIST ispc-1.23.0.gh.tar.gz 19624959 BLAKE2B 08cf817bdd4cd76121dd6c9586ef5f3f9296e7a3b509c51db6413fb62aee0b462ae8baa9fd9497b20c67d4df90149eba16a48b61dd8793c5b64c95a21b13e5d8 SHA512 34cd2572cdaf38f7911ffe52dfb7346f1607de1f81635bdf94e365dee810b30ddeb090eee4a592d9331bb051498172bfd868cd8de9c38bed388d7207a30ac0d8
-EBUILD ispc-1.22.0-r1.ebuild 2290 BLAKE2B 7cf8a43e70237407bc7fb99e44c8b53ea0bb4ce63d2f4e6e21f5dc5a42d7e47f3cd02b5bbf1fbe80c55204573c5906899628bc9c3ecea9ccf1bc9d1316a7faf8 SHA512 bc67aab886b423087fd4c271d561c2c0f6b6b4f3517ee9bb2a06e1351d86b680b04b76e26692ba3172727d8a82506578105c8739ef3d0b35fe9a2043eba9374f
EBUILD ispc-1.23.0.ebuild 2305 BLAKE2B 522905c18bb87d34e244f1e5a956291ac2fafc1d8d5331fca62c2152d60d6458a0932079b3576d69ab6e23822520d8c0a62212ecd93e1341e99eac8dc5838498 SHA512 5aafda25901eaacc4706e23b2ca05db4f4debaa6b64076be1df1b0ef54111f935aaeb2db7056934e1281f979e70683a3c2bbe00696a7f8164ca97015d28d9b8c
MISC metadata.xml 509 BLAKE2B b605dfbff352fab4fcc58ad46f89f97d5db8522de237a0623021c521231798ad00b2b8cd82ce6840d86cfebbe185e6e767e8d0ec276b03a68554ecad20e6b96d SHA512 eae5fcfb0d56190f969ac83012624965b00bd757d8be0bbafce74ab1ea119dc4ee0c33076dd447fabf0a6a6d5f1e2783b54f6c59ebd7aa0a35a4a27df7db01f9
diff --git a/dev-lang/ispc/ispc-1.22.0-r1.ebuild b/dev-lang/ispc/ispc-1.22.0-r1.ebuild
deleted file mode 100644
index 9fec0c98ea60..000000000000
--- a/dev-lang/ispc/ispc-1.22.0-r1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-LLVM_MAX_SLOT=17
-
-inherit cmake llvm multiprocessing python-any-r1 toolchain-funcs
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="
- https://ispc.github.io/
- https://github.com/ispc/ispc/
-"
-SRC_URI="
- https://github.com/ispc/ispc/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="examples gpu openmp test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):=
- sys-libs/ncurses:=
- gpu? ( dev-libs/level-zero:= )
- !openmp? ( dev-cpp/tbb:= )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- app-alternatives/yacc
- app-alternatives/lex
- ${PYTHON_DEPS}
-"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- if use amd64; then
- # On amd64 systems, build system enables x86/i686 build too.
- # This ebuild doesn't even have multilib support, nor need it.
- # https://bugs.gentoo.org/730062
- ewarn "Removing auto-x86 build on amd64"
- sed -i -e 's:set(target_arch "i686"):return():' cmake/GenerateBuiltins.cmake || die
- fi
-
- # do not require bundled gtest
- mkdir -p ispcrt/tests/vendor/google/googletest || die
- cat > ispcrt/tests/vendor/google/googletest/CMakeLists.txt <<-EOF || die
- find_package(GTest)
- EOF
- # remove hacks that break unbundling
- sed -i -e '/gmock/d' -e '/install/,$d' ispcrt/tests/CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DARM_ENABLED=$(usex arm)
- -DCMAKE_SKIP_RPATH=ON
- -DISPC_INCLUDE_EXAMPLES=OFF
- -DISPC_INCLUDE_TESTS=$(usex test)
- -DISPC_INCLUDE_UTILS=OFF
- -DISPCRT_BUILD_GPU=$(usex gpu)
- -DISPCRT_BUILD_TASK_MODEL=$(usex openmp OpenMP TBB)
- )
- cmake_src_configure
-}
-
-src_test() {
- # Inject path to prevent using system ispc
- local -x PATH="${BUILD_DIR}/bin:${PATH}"
- "${EPYTHON}" ./run_tests.py "-j$(makeopts_jobs)" -v ||
- die "Testing failed under ${EPYTHON}"
-}
-
-src_install() {
- cmake_src_install
-
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- fi
-}