summaryrefslogtreecommitdiff
path: root/dev-lang/ispc/ispc-1.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ispc/ispc-1.9.2.ebuild')
-rw-r--r--dev-lang/ispc/ispc-1.9.2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-lang/ispc/ispc-1.9.2.ebuild b/dev-lang/ispc/ispc-1.9.2.ebuild
deleted file mode 100644
index d1c2c2331127..000000000000
--- a/dev-lang/ispc/ispc-1.9.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit toolchain-funcs python-any-r1
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="https://ispc.github.com/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ispc/ispc.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=sys-devel/clang-3.0:*
- >=sys-devel/llvm-3.0:*
- "
-DEPEND="
- ${RDEPEND}
- ${PYTHON_DEPS}
- sys-devel/bison
- sys-devel/flex
- "
-
-src_compile() {
- #make all slient commands ("@") verbose and remove -Werror (ispc/ispc#1295)
- sed -e '/^\t@/s/@//' -e 's/-Werror//' -i Makefile || die
- emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
-}
-
-src_install() {
- dobin ispc
- dodoc README.rst
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r examples/*
- fi
-}