summaryrefslogtreecommitdiff
path: root/dev-lang/ispc/ispc-1.14.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ispc/ispc-1.14.1.ebuild')
-rw-r--r--dev-lang/ispc/ispc-1.14.1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-lang/ispc/ispc-1.14.1.ebuild b/dev-lang/ispc/ispc-1.14.1.ebuild
index 58c0534cc5bf..0dd7a8767786 100644
--- a/dev-lang/ispc/ispc-1.14.1.ebuild
+++ b/dev-lang/ispc/ispc-1.14.1.ebuild
@@ -5,7 +5,9 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake toolchain-funcs python-any-r1
+inherit cmake toolchain-funcs python-any-r1 llvm
+
+LLVM_MAX_SLOT=10
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="https://ispc.github.com/"
@@ -22,10 +24,8 @@ LICENSE="BSD BSD-2 UoI-NCSA"
SLOT="0"
IUSE="examples"
-RDEPEND="
- >=sys-devel/clang-3.0:*
- >=sys-devel/llvm-3.0:*
- "
+RDEPEND="<sys-devel/clang-11:="
+
DEPEND="
${RDEPEND}
${PYTHON_DEPS}
@@ -41,6 +41,10 @@ PATCHES=(
"${FILESDIR}/${PN}-1.13.0-werror.patch"
)
+llvm_check_deps() {
+ has_version -d "sys-devel/clang:${LLVM_SLOT}"
+}
+
src_prepare() {
if use amd64; then
# On amd64 systems, build system enables x86/i686 build too.