summaryrefslogtreecommitdiff
path: root/dev-lang/go-bootstrap/go-bootstrap-1.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/go-bootstrap/go-bootstrap-1.19.1.ebuild')
-rw-r--r--dev-lang/go-bootstrap/go-bootstrap-1.19.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-lang/go-bootstrap/go-bootstrap-1.19.1.ebuild b/dev-lang/go-bootstrap/go-bootstrap-1.19.1.ebuild
deleted file mode 100644
index 200cc1937fd7..000000000000
--- a/dev-lang/go-bootstrap/go-bootstrap-1.19.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Bootstrap package for dev-lang/go"
-HOMEPAGE="https://golang.org"
-BOOTSTRAP_DIST="https://dev.gentoo.org/~williamh/dist"
-SRC_URI="
- amd64? ( ${BOOTSTRAP_DIST}/go-linux-amd64-bootstrap-${PV}.tbz )
- arm? ( ${BOOTSTRAP_DIST}/go-linux-arm-bootstrap-${PV}.tbz )
- arm64? ( ${BOOTSTRAP_DIST}/go-linux-arm64-bootstrap-${PV}.tbz )
- loong? ( ${BOOTSTRAP_DIST}/go-linux-loong64-bootstrap-${PV}.tbz )
- mips? (
- abi_mips_o32? (
- big-endian? ( ${BOOTSTRAP_DIST}/go-linux-mips-bootstrap-${PV}.tbz )
- !big-endian? ( ${BOOTSTRAP_DIST}/go-linux-mipsle-bootstrap-${PV}.tbz )
- )
- abi_mips_n64? (
- big-endian? ( ${BOOTSTRAP_DIST}/go-linux-mips64-bootstrap-${PV}.tbz )
- !big-endian? ( ${BOOTSTRAP_DIST}/go-linux-mips64le-bootstrap-${PV}.tbz )
- )
- )
- ppc64? (
- big-endian? ( ${BOOTSTRAP_DIST}/go-linux-ppc64-bootstrap-${PV}.tbz )
- !big-endian? ( ${BOOTSTRAP_DIST}/go-linux-ppc64le-bootstrap-${PV}.tbz )
- )
- riscv? ( ${BOOTSTRAP_DIST}/go-linux-riscv64-bootstrap-${PV}.tbz )
- s390? ( ${BOOTSTRAP_DIST}/go-linux-s390x-bootstrap-${PV}.tbz )
- x86? ( ${BOOTSTRAP_DIST}/go-linux-386-bootstrap-${PV}.tbz )
- x64-macos? ( ${BOOTSTRAP_DIST}/go-darwin-amd64-bootstrap-${PV}.tbz )
- arm64-macos? ( ${BOOTSTRAP_DIST}/go-darwin-arm64-bootstrap-${PV}.tbz )
- x64-solaris? ( ${BOOTSTRAP_DIST}/go-solaris-amd64-bootstrap-${PV}.tbz )
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos ~x64-solaris"
-IUSE="abi_mips_n64 abi_mips_o32 big-endian"
-RESTRICT="strip"
-QA_PREBUILT="*"
-
-S="${WORKDIR}"
-
-src_install() {
- dodir /usr/lib
- mv go-*-bootstrap "${ED}/usr/lib/go-bootstrap" || die
-
- # testdata directories are not needed on the installed system
- rm -fr $(find "${ED}"/usr/lib/go-bootstrap -iname testdata -type d -print)
-}