summaryrefslogtreecommitdiff
path: root/dev-lang/gnat-gpl/gnat-gpl-2017.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gnat-gpl/gnat-gpl-2017.ebuild')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2017.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2017.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2017.ebuild
index dde7fbf04a93..bdcc9a45caf9 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2017.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2017.ebuild
@@ -36,7 +36,7 @@ SRC_URI+="
LICENSE+=" GPL-2 GPL-3"
SLOT="${TOOLCHAIN_GCC_PV}"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="bootstrap"
RDEPEND="!sys-devel/gcc:${TOOLCHAIN_GCC_PV}"
@@ -70,16 +70,16 @@ pkg_setup() {
if [[ ${gnatpath} != "." ]] ; then
GNATMAKE="${gnatpath}/${GNATMAKE}"
fi
+}
+src_unpack() {
if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
eerror "You need a gcc compiler that provides the Ada Compiler:"
eerror "1) use gcc-config to select the right compiler or"
eerror "2) set the bootstrap use flag"
die "ada compiler not available"
fi
-}
-src_unpack() {
GCC_A_FAKEIT="
${P}-src.tar.gz
${MYP}.tar.gz