summaryrefslogtreecommitdiff
path: root/dev-lang/ghc/ghc-9.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/ghc-9.0.2.ebuild')
-rw-r--r--dev-lang/ghc/ghc-9.0.2.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/dev-lang/ghc/ghc-9.0.2.ebuild b/dev-lang/ghc/ghc-9.0.2.ebuild
index 49acb75d8338..e943844a1b69 100644
--- a/dev-lang/ghc/ghc-9.0.2.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2.ebuild
@@ -424,6 +424,7 @@ src_prepare() {
# ffi headers don't get included in the binpkg for some reason
for f in "${WORKDIR}/usr/$(get_libdir)/${PN}-${BIN_PV}/include/"{ffi.h,ffitarget.h}
do
+ mkdir -p "$(dirname "${f}")"
[[ -e "${f}" ]] || ln -sf "$($(tc-getPKG_CONFIG) --cflags-only-I libffi | sed "s/-I//g" | tr -d " ")/$(basename "${f}")" "${f}" || die
done