summaryrefslogtreecommitdiff
path: root/dev-lang/ghc/ghc-9.0.2-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/ghc-9.0.2-r3.ebuild')
-rw-r--r--dev-lang/ghc/ghc-9.0.2-r3.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-lang/ghc/ghc-9.0.2-r3.ebuild b/dev-lang/ghc/ghc-9.0.2-r3.ebuild
index 1cd220d817eb..21f2dedfd9de 100644
--- a/dev-lang/ghc/ghc-9.0.2-r3.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2-r3.ebuild
@@ -458,6 +458,9 @@ src_prepare() {
[[ -e "${f}" ]] || ln -sf "$($(tc-getPKG_CONFIG) --cflags-only-I libffi | sed "s/-I//g" | tr -d " ")/$(basename "${f}")" "${f}" || die
done
+
+ eapply "${FILESDIR}"/${PN}-9.0.2-sphinx-6.patch
+
if use binary; then
if use prefix; then
relocate_ghc "${EPREFIX}"
@@ -544,7 +547,6 @@ src_prepare() {
eapply "${FILESDIR}"/latomic-subword
eapply "${WORKDIR}"/${P}-riscv64-llvm.patch
eapply "${FILESDIR}"/${PN}-9.0.2-fptools.patch # clang-16 workaround
- eapply "${FILESDIR}"/${PN}-9.0.2-sphinx-6.patch
# mingw32 target
pushd "${S}/libraries/Win32"