summaryrefslogtreecommitdiff
path: root/dev-lang/ghc/ghc-8.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/ghc-8.0.2.ebuild')
-rw-r--r--dev-lang/ghc/ghc-8.0.2.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/ghc/ghc-8.0.2.ebuild b/dev-lang/ghc/ghc-8.0.2.ebuild
index 6e573c0fff30..48eb8d91db6e 100644
--- a/dev-lang/ghc/ghc-8.0.2.ebuild
+++ b/dev-lang/ghc/ghc-8.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -293,6 +293,7 @@ relocate_ghc() {
# but then USE=binary would result in installing
# in '${bin_libdir}'
mv "${bin_ghc_prefix}/${bin_libdir}" "${bin_ghc_prefix}/$(get_libdir)" || die
+ bin_libpath=${bin_ghc_prefix}/$(get_libdir)
relocate_path "/usr/${bin_libdir}" "/usr/$(get_libdir)" \
"${WORKDIR}/usr/bin/$(cross)ghc-${GHC_PV}" \