summaryrefslogtreecommitdiff
path: root/dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch')
-rw-r--r--dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch b/dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch
new file mode 100644
index 000000000000..ee4132bb2ee8
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/876187
+
+Bump max LLVM to 14. Validated on arm64.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -681,7 +681,7 @@ AC_SUBST(InstallNameToolCmd)
+ # versions of LLVM simultaneously, but that stopped working around
+ # 3.5/3.6 release of LLVM.
+ LlvmMinVersion=9 # inclusive
+-LlvmMaxVersion=14 # not inclusive
++LlvmMaxVersion=15 # not inclusive
+ AC_SUBST([LlvmMinVersion])
+ AC_SUBST([LlvmMaxVersion])
+ sUPPORTED_LLVM_VERSION_MIN=$(echo \($LlvmMinVersion\) | sed 's/\./,/')