summaryrefslogtreecommitdiff
path: root/dev-lang/fennel
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/fennel')
-rw-r--r--dev-lang/fennel/Manifest3
-rw-r--r--dev-lang/fennel/fennel-0.9.1.ebuild32
-rw-r--r--dev-lang/fennel/metadata.xml29
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-lang/fennel/Manifest b/dev-lang/fennel/Manifest
new file mode 100644
index 000000000000..4aa072db68cb
--- /dev/null
+++ b/dev-lang/fennel/Manifest
@@ -0,0 +1,3 @@
+DIST fennel-0.9.1.tar.gz 203441 BLAKE2B 74f461b3e7a24cdae0c8dde590814cb9753a12ab62e797746cc8753d178007a09084037e443d8309fa11ff309a5c6bf6c2e369942ef357aa0402883cef278542 SHA512 87e7ffbef0b49499a93255f50e77f53b9be4faa6d4609d8d65e3a64470bbf07b49a55e7dd547fda4b0e5fe0f4f1e6ece18282cc89955a57ed0a50be8dc01261c
+EBUILD fennel-0.9.1.ebuild 698 BLAKE2B d3c81fa72bb2170bf88561787454a3c0d3989a03fe45108940131a29e5ee7a09cc0cdecb4d79bcfe1eaf37d203ff873dddbdea88a575e6de5b7ac01c265bcae0 SHA512 0815d701b3dc08d86bf39187e47e7c595c9ec9814fe467fbdc4c2b7453e489da1b631af058dd38fc853ef3a1835c59b33c750977baf4a9859bc539d211332fab
+MISC metadata.xml 1139 BLAKE2B e153636da247b351e1c8844b523e44620ba59674d6b118d65c860b9cd1ceffb69af426704ba3dddfa9722775dae8a8ac7ff521d1eae40e049e1ce82253ab0273 SHA512 ac1acd2a6bc0b2367f2101d28a7aa66143baea7d4ff74656933d3ac507de22f19bbf3d8474a74e804e7aeac40f058a106199c2d2055a5b76d66a3e2a41ebf4a1
diff --git a/dev-lang/fennel/fennel-0.9.1.ebuild b/dev-lang/fennel/fennel-0.9.1.ebuild
new file mode 100644
index 000000000000..856dc1383b01
--- /dev/null
+++ b/dev-lang/fennel/fennel-0.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1,3,4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="Lisp-like language that compiles to Lua"
+HOMEPAGE="https://fennel-lang.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~technomancy/fennel"
+else
+ SRC_URI="https://git.sr.ht/~technomancy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake LUA_LIB_DIR="${ED}/$(lua_get_lmod_dir)" PREFIX="${ED}/usr" install
+ doman ${PN}.1
+ dodoc *.md
+}
diff --git a/dev-lang/fennel/metadata.xml b/dev-lang/fennel/metadata.xml
new file mode 100644
index 000000000000..7be4ec2ae425
--- /dev/null
+++ b/dev-lang/fennel/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fennel is a lisp that compiles to Lua. It aims to be easy to use,
+ expressive, and has almost zero overhead compared to handwritten Lua.
+
+ - Full Lua compatibility - You can use any function or library from Lua.
+ - Zero overhead - Compiled code should be just as or more efficient
+ than hand-written Lua.
+ - Compile-time macros - Ship compiled code with no runtime dependency
+ on Fennel.
+ - Embeddable - Fennel is a one-file library as well as an executable.
+ Embed it in other programs to support runtime extensibility and
+ interactive development.
+
+ At https://fennel-lang.org there's a live in-browser REPL you can use
+ without installing anything.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/bakpakin/Fennel/issues</bugs-to>
+ <remote-id type="github">bakpakin/Fennel</remote-id>
+ </upstream>
+</pkgmetadata>