summaryrefslogtreecommitdiff
path: root/dev-lang/fennel/fennel-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/fennel/fennel-0.9.1.ebuild')
-rw-r--r--dev-lang/fennel/fennel-0.9.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lang/fennel/fennel-0.9.1.ebuild b/dev-lang/fennel/fennel-0.9.1.ebuild
new file mode 100644
index 000000000000..856dc1383b01
--- /dev/null
+++ b/dev-lang/fennel/fennel-0.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1,3,4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="Lisp-like language that compiles to Lua"
+HOMEPAGE="https://fennel-lang.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~technomancy/fennel"
+else
+ SRC_URI="https://git.sr.ht/~technomancy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake LUA_LIB_DIR="${ED}/$(lua_get_lmod_dir)" PREFIX="${ED}/usr" install
+ doman ${PN}.1
+ dodoc *.md
+}