summaryrefslogtreecommitdiff
path: root/dev-lang/eisl/eisl-2.60.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/eisl/eisl-2.60.ebuild')
-rw-r--r--dev-lang/eisl/eisl-2.60.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/eisl/eisl-2.60.ebuild b/dev-lang/eisl/eisl-2.60.ebuild
new file mode 100644
index 000000000000..d3860f96fe30
--- /dev/null
+++ b/dev-lang/eisl/eisl-2.60.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
+HOMEPAGE="https://github.com/sasagawa888/eisl/"
+SRC_URI="https://github.com/sasagawa888/eisl/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests run cppcheck (and fail)
+
+DOCS=( README-ja.md README.md documents )
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.50-Makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" clean all
+}
+
+src_install() {
+ dobin edlis eisl
+
+ insinto /usr/lib/${PN}
+ doins library/*
+
+ einstalldocs
+}