summaryrefslogtreecommitdiff
path: root/dev-lang/crystal/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/crystal/files')
-rw-r--r--dev-lang/crystal/files/crystal-0.24.0-verbose-LDFLAGS.patch9
-rw-r--r--dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-sandbox.patch37
-rw-r--r--dev-lang/crystal/files/crystal-0.27.0-gentoo-tests-network-sandbox.patch44
-rw-r--r--dev-lang/crystal/files/crystal-0.29.0-no-usr-lib.patch14
4 files changed, 14 insertions, 90 deletions
diff --git a/dev-lang/crystal/files/crystal-0.24.0-verbose-LDFLAGS.patch b/dev-lang/crystal/files/crystal-0.24.0-verbose-LDFLAGS.patch
deleted file mode 100644
index 3d02a119f858..000000000000
--- a/dev-lang/crystal/files/crystal-0.24.0-verbose-LDFLAGS.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/Makefile b/Makefile
-index eff69e5..5c0c024 100644
---- a/Makefile
-+++ b/Makefile
-@@ -28,3 +28,3 @@ SOURCES := $(shell find src -name '*.cr')
- SPEC_SOURCES := $(shell find spec -name '*.cr')
--FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )
-+FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(verbose),--verbose )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )
- SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )
diff --git a/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-sandbox.patch b/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-sandbox.patch
deleted file mode 100644
index 4bd779a834c8..000000000000
--- a/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-sandbox.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/spec/std/file_spec.cr b/spec/std/file_spec.cr
-index 4a08b7d..cb1b28c 100644
---- a/spec/std/file_spec.cr
-+++ b/spec/std/file_spec.cr
-@@ -1026,7 +1026,8 @@ describe "File" do
- end
- end
-
-- it "raises if file cannot be accessed" do
-+ # On linux it's "Permission denied", not "Operation not permitted"
-+ pending "raises if file cannot be accessed" do
- expect_raises Errno, "Operation not permitted" do
- File.touch("/bin/ls")
- end
-diff --git a/spec/std/process_spec.cr b/spec/std/process_spec.cr
-index 4a36f18..0cd63a8 100644
---- a/spec/std/process_spec.cr
-+++ b/spec/std/process_spec.cr
-@@ -115,14 +115,16 @@ describe Process do
- end
-
- describe "environ" do
-- it "clears the environment" do
-+ #gentoo's sandbox keeps sandbox environment
-+ pending "clears the environment" do
- value = Process.run("env", clear_env: true) do |proc|
- proc.output.gets_to_end
- end
- value.should eq("")
- end
-
-- it "sets an environment variable" do
-+ #gentoo's sandbox keeps sandbox environment
-+ pending "sets an environment variable" do
- env = {"FOO" => "bar"}
- value = Process.run("env", clear_env: true, env: env) do |proc|
- proc.output.gets_to_end
diff --git a/dev-lang/crystal/files/crystal-0.27.0-gentoo-tests-network-sandbox.patch b/dev-lang/crystal/files/crystal-0.27.0-gentoo-tests-network-sandbox.patch
deleted file mode 100644
index 0ba0f18f73d8..000000000000
--- a/dev-lang/crystal/files/crystal-0.27.0-gentoo-tests-network-sandbox.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/spec/std/socket/tcp_server_spec.cr
-+++ b/spec/std/socket/tcp_server_spec.cr
-@@ -76,13 +76,17 @@ describe TCPServer do
- TCPServer.new("localhost", unused_local_port)
- end
-
-- it "raises when host doesn't exist" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # Socket::Error: getaddrinfo: Temporary failure in name resolution
-+ pending "raises when host doesn't exist" do
- expect_raises(Socket::Error, "No address") do
- TCPServer.new("doesnotexist.example.org.", 12345)
- end
- end
-
-- it "raises (rather than segfault on darwin) when host doesn't exist and port is 0" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # Socket::Error: getaddrinfo: Temporary failure in name resolution
-+ pending "raises (rather than segfault on darwin) when host doesn't exist and port is 0" do
- expect_raises(Socket::Error, "No address") do
- TCPServer.new("doesnotexist.example.org.", 0)
- end
---- a/spec/std/socket/tcp_socket_spec.cr
-+++ b/spec/std/socket/tcp_socket_spec.cr
-@@ -56,13 +56,17 @@ describe TCPSocket do
- end
- end
-
-- it "raises when host doesn't exist" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # Socket::Error: getaddrinfo: Temporary failure in name resolution
-+ pending "raises when host doesn't exist" do
- expect_raises(Socket::Error, "No address") do
- TCPSocket.new("doesnotexist.example.org.", 12345)
- end
- end
-
-- it "raises (rather than segfault on darwin) when host doesn't exist and port is 0" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # Socket::Error: getaddrinfo: Temporary failure in name resolution
-+ pending "raises (rather than segfault on darwin) when host doesn't exist and port is 0" do
- expect_raises(Socket::Error, "No address") do
- TCPSocket.new("doesnotexist.example.org.", 0)
- end
diff --git a/dev-lang/crystal/files/crystal-0.29.0-no-usr-lib.patch b/dev-lang/crystal/files/crystal-0.29.0-no-usr-lib.patch
new file mode 100644
index 000000000000..15f2ac75c099
--- /dev/null
+++ b/dev-lang/crystal/files/crystal-0.29.0-no-usr-lib.patch
@@ -0,0 +1,14 @@
+On amd64 linux /usr/lib does not match default 64-bit ABI.
+
+Let's rely on default compiler and linker paths instead.
+--- a/src/compiler/crystal/codegen/link.cr
++++ b/src/compiler/crystal/codegen/link.cr
+@@ -105,7 +105,7 @@ module Crystal
+ end
+
+ private def lib_flags_posix
+- library_path = ["/usr/lib", "/usr/local/lib"]
++ library_path = [] of String
+ has_pkg_config = nil
+
+ String.build do |flags|