summaryrefslogtreecommitdiff
path: root/dev-lang/boogie/boogie-3.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/boogie/boogie-3.0.4.ebuild')
-rw-r--r--dev-lang/boogie/boogie-3.0.4.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-lang/boogie/boogie-3.0.4.ebuild b/dev-lang/boogie/boogie-3.0.4.ebuild
index fd4d8b31113f..8cb18a16b354 100644
--- a/dev-lang/boogie/boogie-3.0.4.ebuild
+++ b/dev-lang/boogie/boogie-3.0.4.ebuild
@@ -234,6 +234,7 @@ PATCHES=( "${FILESDIR}/${PN}-3.0.4-disable-analyzers.patch" )
CHECKREQS_DISK_BUILD="2G"
DOTNET_PKG_PROJECTS=( Source/BoogieDriver/BoogieDriver.csproj )
+DOTNET_PKG_BUILD_EXTRA_ARGS=( -p:RollForward=Major )
pkg_setup() {
check-reqs_pkg_setup
@@ -243,16 +244,12 @@ pkg_setup() {
src_unpack() {
dotnet-pkg_src_unpack
- if [[ -n ${EGIT_REPO_URI} ]] ; then
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
git-r3_src_unpack
fi
}
src_prepare() {
- # Bump used .NET version: 6.0 -> 7.0
- sed -e "s|net6.0|net7.0|g" \
- -i "${S}/Source/Directory.Build.props" || die
-
# Remove bad tests.
local -a bad_tests=(
civl/inductive-sequentialization/BroadcastConsensus.bpl