summaryrefslogtreecommitdiff
path: root/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.0.ebuild')
-rw-r--r--dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.0.ebuild b/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.0.ebuild
new file mode 100644
index 000000000000..f0e3f45e98bc
--- /dev/null
+++ b/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+SCALA_VERSION="2.13"
+
+DESCRIPTION="Scala language-based scripting and REPL"
+HOMEPAGE="https://ammonite.io/"
+SRC_URI="https://github.com/lihaoyi/Ammonite/releases/download/${PV}/${SCALA_VERSION}-${PV} -> ammonite-${PV}"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_install() {
+ newbin "${DISTDIR}/ammonite-${PV}" amm
+}