summaryrefslogtreecommitdiff
path: root/dev-java
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/Manifest.gzbin52587 -> 52592 bytes
-rw-r--r--dev-java/jffi/Manifest1
-rw-r--r--dev-java/jffi/files/jffi_maven-build.xml259
3 files changed, 0 insertions, 260 deletions
diff --git a/dev-java/Manifest.gz b/dev-java/Manifest.gz
index 14a51e6ec95f..7d6ba21e6379 100644
--- a/dev-java/Manifest.gz
+++ b/dev-java/Manifest.gz
Binary files differ
diff --git a/dev-java/jffi/Manifest b/dev-java/jffi/Manifest
index 168085968725..93c7259fc9e1 100644
--- a/dev-java/jffi/Manifest
+++ b/dev-java/jffi/Manifest
@@ -1,5 +1,4 @@
AUX jffi-1.3.8-GNUmakefile.patch 805 BLAKE2B 9c9c1f8daeca9527dd364c303311554004ed6f0b7964bfa68f004bfd6f3aa39fb817d88afc82c4710226c25d752c55c2e43002fe7557d6c7c705a60bf4903543 SHA512 f1ff970c7dd8630a8fcadb1689034a28dd407f3c7efc4df4b6dad2c458da55e71f8b646bed4e11dab089c28c7af0e6eacc067ab68c0ddd856a1102b235cd02b7
-AUX jffi_maven-build.xml 11287 BLAKE2B 01ef4db6fef9d963bd52e0c15317ae836b629d9b22987c2d69a393d5513ab60bf2b062a083bb5b1a04301493c982f3926d5c9225972f7861e4ad668c9fc7a1f1 SHA512 56ebbb915d359f3eacf170d08fc1cf30f6efe900c91df0259a1fb69c6873ae839df829227b55e1538b4435387a82ec3e774180cfb531eb747e05a562aa7b97c7
DIST jffi-1.3.9.tar.gz 3193992 BLAKE2B bcd2dba3f9528c293aebb13a8fbd0b2fd7afcbae0cc5fa231f7e8ab190b834adc9e3f40bfc1211d0019a34a9edbaf8810f44b88f3c44b1e3b8065b2b80ccc6dc SHA512 21bf6997c64c0764c1fe86c9ab9b854037241489789f443a3337253ecc95100c94723a57165c85eed7a6c3837b8c04751af4a1fb5873a9c9fcd9a4535b68fc10
EBUILD jffi-1.3.9-r1.ebuild 3285 BLAKE2B df02b9374bbc00966b973dc761d28f6f635a92d0c619c2777559e299c2bc30cec58ff2813d92cce13c950685dd05bee3de9be8b0058363b3ebf65b3c1cf1c948 SHA512 d02a840a1182cb3de7a0a82a9dd804d6f7237e61fa50f4cd2055aaf43aa945dcce74a2e9e7a315a5c2e51ff85b6cabe0ad7236665865fef0880235fd64c70e37
MISC metadata.xml 320 BLAKE2B 4b1ac90322eb9faf01b397b7b4eea9167648abf3a89693a3bb28b27f5015b03c20c3b1b7843509686c8a827be8d4ea37f40fdf6ddaae418eec2dfa3b1797ffae SHA512 0daa4f9c85c906fdbd2fb652257c4d8ff52d88738e8e37e6bed49fdee6bb8aecefcd06e39fbe1262a3a0af73d2e1f4cfc8d0fc56b109bc686975ed41e54a68c9
diff --git a/dev-java/jffi/files/jffi_maven-build.xml b/dev-java/jffi/files/jffi_maven-build.xml
deleted file mode 100644
index d8114185ee41..000000000000
--- a/dev-java/jffi/files/jffi_maven-build.xml
+++ /dev/null
@@ -1,259 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 1/9/12 9:52 AM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="jffi-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="jffi-1.0.11"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.1"
- verbose="false"
- fork="false"
- source="1.3">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.1"
- verbose="false"
- fork="false"
- source="1.3">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- <mkdir dir="${maven.repo.local}"/>
- <mkdir dir="${maven.repo.local}/junit/junit/4.8.2"/>
- <get src="http://repository.jboss.com/maven2/junit/junit/4.8.2/junit-4.8.2.jar"
- dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://snapshots.jboss.org/maven2/junit/junit/4.8.2/junit-4.8.2.jar"
- dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repository.jboss.org/maven2//junit/junit/4.8.2/junit-4.8.2.jar"
- dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="https://repository.jboss.org/nexus/content/groups/public-jboss//junit/junit/4.8.2/junit-4.8.2.jar"
- dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="https://oss.sonatype.org/content/repositories/snapshots/junit/junit/4.8.2/junit-4.8.2.jar"
- dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo1.maven.org/maven2/junit/junit/4.8.2/junit-4.8.2.jar"
- dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- </target>
-
-</project>